summaryrefslogtreecommitdiff
path: root/dev-python/lit/lit-6.0.9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-09 16:53:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-03-09 16:53:27 +0000
commit80208fb578cf92cc308906660ca6d7860c6b2a1f (patch)
tree6f06818031b553c506fc10dfe9908a835df288aa /dev-python/lit/lit-6.0.9999.ebuild
parent06a7b5647e11a8ddf69b1c3d3ded6a8ba28b923e (diff)
gentoo resync : 09.03.2018
Diffstat (limited to 'dev-python/lit/lit-6.0.9999.ebuild')
-rw-r--r--dev-python/lit/lit-6.0.9999.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/dev-python/lit/lit-6.0.9999.ebuild b/dev-python/lit/lit-6.0.9999.ebuild
index f167a14c32b7..d3e98d7342bd 100644
--- a/dev-python/lit/lit-6.0.9999.ebuild
+++ b/dev-python/lit/lit-6.0.9999.ebuild
@@ -4,7 +4,7 @@
EAPI=6
PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-inherit distutils-r1 git-r3
+inherit distutils-r1 git-r3 multiprocessing
DESCRIPTION="A stand-alone install of the LLVM suite testing tool"
HOMEPAGE="https://llvm.org/"
@@ -36,5 +36,6 @@ src_unpack() {
}
python_test() {
- ./lit.py -vv tests || die
+ ./lit.py -j "${LIT_JOBS:-$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")}" \
+ -vv tests || die
}