summaryrefslogtreecommitdiff
path: root/dev-python/lit/lit-16.0.0_pre20221210.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-11 03:21:49 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-11 03:21:49 +0000
commitecd86b32a8f0b6be58bbb4b294ce38f1fbd7d3dc (patch)
tree11371cd9091867fc72344384665285aa7a19efd6 /dev-python/lit/lit-16.0.0_pre20221210.ebuild
parentb118032096b3380de251b5de2466f5198fd2930a (diff)
gentoo auto-resync : 11:12:2022 - 03:21:49
Diffstat (limited to 'dev-python/lit/lit-16.0.0_pre20221210.ebuild')
-rw-r--r--dev-python/lit/lit-16.0.0_pre20221210.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/lit/lit-16.0.0_pre20221210.ebuild b/dev-python/lit/lit-16.0.0_pre20221210.ebuild
new file mode 100644
index 000000000000..8ace6ca8b915
--- /dev/null
+++ b/dev-python/lit/lit-16.0.0_pre20221210.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1 llvm.org
+
+DESCRIPTION="A stand-alone install of the LLVM suite testing tool"
+HOMEPAGE="https://llvm.org/"
+
+LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
+SLOT="0"
+KEYWORDS=""
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# Tests require 'FileCheck' and 'not' utilities (from llvm)
+BDEPEND="
+ test? (
+ dev-python/psutil[${PYTHON_USEDEP}]
+ sys-devel/llvm
+ )
+"
+
+LLVM_COMPONENTS=( llvm/utils/lit )
+llvm.org_set_globals
+
+# TODO: move the manpage generation here (from sys-devel/llvm)
+
+src_prepare() {
+ cd "${WORKDIR}" || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local -x LIT_PRESERVES_TMP=1
+ local litflags=$(get_lit_flags)
+ ./lit.py ${litflags//;/ } tests || die
+}