summaryrefslogtreecommitdiff
path: root/dev-python/line_profiler
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
commit46eedbedafdb0040c37884982d4c775ce277fb7b (patch)
treedb33a91259730be84999e13a8d8168c799f50ac0 /dev-python/line_profiler
parente23a08d0c97a0cc415aaa165da840b056f93c997 (diff)
gentoo resync : 20.10.2021
Diffstat (limited to 'dev-python/line_profiler')
-rw-r--r--dev-python/line_profiler/Manifest2
-rw-r--r--dev-python/line_profiler/line_profiler-3.3.0.ebuild49
2 files changed, 0 insertions, 51 deletions
diff --git a/dev-python/line_profiler/Manifest b/dev-python/line_profiler/Manifest
index 718e99bf3d7b..62ba86f06105 100644
--- a/dev-python/line_profiler/Manifest
+++ b/dev-python/line_profiler/Manifest
@@ -1,5 +1,3 @@
-DIST line_profiler-3.3.0.gh.tar.gz 52791 BLAKE2B e3499f5274045d158620fa890df6e725a99c3df019bb4515434213d2c60d52d400d7a7dfce64b153422722ea388f73318818485c9747e6eace2d81c457f93a7f SHA512 37680c55a551c73aed7a3ee2333c523f0617e01cda6db98060f15fe36990c8c8bc08bd5848e569f269bf11590776290ee0980046cce745df8e54268d7991559b
DIST line_profiler-3.3.1.gh.tar.gz 56700 BLAKE2B 030c0fc742a6773ebb55a54a3c21d3d5e5d6d5d258a2c3cd2071ff93917411b65e100bfc6549d9c60d9a7c361c53b291d8b81538acaf5b83665c04129d25bc02 SHA512 8a3704a6df2abe71283cb2da23b738932c6f4b42aedcdefda0d318fd4b894d56831a855c4be4430657308530a04d1e96b0e15a60edca06621bdd5370c0bf9911
-EBUILD line_profiler-3.3.0.ebuild 1072 BLAKE2B 29ce0340d810abcda5eecf530928180a50223ac4f724a328ff8d477f4ba6a621d67c90d95960d373a643e6c2fb75a61fe2ff5330ca35f318c75a917fe490ef7b SHA512 5ac63f08cbd550a37e99f98bd2df06579a2cf507187b1ec7ca2a1e0bc738443351dcb680a022b083f692570d6300b57a418198c73ea41fda6e7029cecd230cb1
EBUILD line_profiler-3.3.1.ebuild 1072 BLAKE2B 6b412fbfd938cf1a646c17aed4cf97a308e8d5af97791ffed24ecdabb3b93e3fdf5f7da2b866cb2023dda6bfeddada7bbf79c9f7d408f5369f383b4924926f48 SHA512 12d0eb3477bd386b3394ad9acb65c5dd120fa67fc8928072aa5da84758a72dd4e11e2c7e3dd69873d6a45a2748709cadcd875c7b92747997d8ca18e7367b8a62
MISC metadata.xml 775 BLAKE2B 6d817146b4f2379141f3def2ab8cb2d69f40e1e7645e714c09ad30a425d14c85c50749ffe2c4d6dec9bf146e294caaf8a1647d2a15d672667932ca7543d0df59 SHA512 745e91051af76df1a7344923dfdfad748fc11bf663c60f3c83a5d434ebfeb218ccc91a314244008bf6a39a4be77b3b3c5457739e1102ba188ddf7c8203b75695
diff --git a/dev-python/line_profiler/line_profiler-3.3.0.ebuild b/dev-python/line_profiler/line_profiler-3.3.0.ebuild
deleted file mode 100644
index 1e0c9050df4c..000000000000
--- a/dev-python/line_profiler/line_profiler-3.3.0.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-# force it to match scikit-build
-CMAKE_MAKEFILE_GENERATOR=ninja
-
-inherit cmake distutils-r1
-
-DESCRIPTION="Line-by-line profiler"
-HOMEPAGE="https://github.com/pyutils/line_profiler/"
-SRC_URI="
- https://github.com/pyutils/line_profiler/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz"
-
-SLOT="0"
-LICENSE="BSD"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="dev-python/ipython[${PYTHON_USEDEP}]"
-# technically, the package claims to support non-scikit-build build
-# but it's clearly unmaintained and broken at the moment
-BDEPEND="
- dev-python/cython[${PYTHON_USEDEP}]
- dev-python/scikit-build[${PYTHON_USEDEP}]
- test? (
- dev-python/coverage[${PYTHON_USEDEP}]
- dev-python/ubelt[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests --install pytest
-
-src_prepare() {
- cmake_src_prepare
- distutils-r1_src_prepare
-}
-
-python_test() {
- distutils_install_for_testing
- cd tests || die
- epytest
-}
-
-python_install() {
- distutils-r1_python_install
- python_optimize
-}