summaryrefslogtreecommitdiff
path: root/dev-python/line_profiler
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-14 06:50:14 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-14 06:50:14 +0000
commitafa8da78d8135ca28150730e9c60af9d875f0a5b (patch)
tree65e94479f29d7591a1bc1d09d1fc1913d785fe6b /dev-python/line_profiler
parent4828c25c25aacf399de429d381288982fd7e0d0e (diff)
gentoo auto-resync : 14:11:2022 - 06:50:13
Diffstat (limited to 'dev-python/line_profiler')
-rw-r--r--dev-python/line_profiler/Manifest2
-rw-r--r--dev-python/line_profiler/line_profiler-3.5.1.ebuild51
2 files changed, 0 insertions, 53 deletions
diff --git a/dev-python/line_profiler/Manifest b/dev-python/line_profiler/Manifest
index 3e638b4c4cea..c007803deda0 100644
--- a/dev-python/line_profiler/Manifest
+++ b/dev-python/line_profiler/Manifest
@@ -1,5 +1,3 @@
-DIST line_profiler-3.5.1.gh.tar.gz 51241 BLAKE2B a3f3cceab9d34062a0b96ce772941bb945f96f7e88f59bb72d08a09fb96db3d9354ce33b0c0088065df5aeb7349c7da37d8697654d9f5130d8bd0b7997306d13 SHA512 4618e57e52b7d7d5ece034735a4ce38dd3a8af57e5b897790be4c8e1ee1757d822d7c1bb76d3c7248432c49c13708bffb9bebbbbf61442de98c5a6ec657cbd57
DIST line_profiler-4.0.0.gh.tar.gz 62856 BLAKE2B 7beb4b63c016d180d1e7e39b0461759593d3ba3ad1c5150b3623890ece3a69ebb65d48f59e8dc3865a19565ab46f2dc8a2a86698abe890d9bd857e1080cbb557 SHA512 d10b9470c686da863c340da7d4af8b6c6b6cb715486a00af1e1d79686c26909b289b8400a4d526520ade6fbbcd58e868a97603345682d5060a9b3ae2fd3495be
-EBUILD line_profiler-3.5.1.ebuild 1045 BLAKE2B 717e12474d45a4fa76a7b0fc69306f10eb2875cbcbe4bd5454109bc8d8b2aaa3d9dd9ee91181b618433028b260addd3a36cead6f4309358c0ca3398694ba0bba SHA512 d7837c050e9100d104880f548382309988badeb9ec79cca03327840c0114f8ebf1ed2b2794f8d963863a22d4727c1cd0ad8419ab7a25c890cd4717ba47675bbc
EBUILD line_profiler-4.0.0.ebuild 743 BLAKE2B 201c439092ccecacebd3e4b8488dc062c1f63f09f7ac86e36948a9f5e9bbc0aac7be8fe2a0eb46751823524da074829942898a97e027b5264fb9b984bb7e1b3a SHA512 b142f02fc8bf01fb33cc74e482ef2629d3b4fa6a864d11e579a0e79bf74eabdf68b7318a994ea9e009cd98d91b0c3c3ae2f37763d58c32d52939878b40709100
MISC metadata.xml 775 BLAKE2B de65859e8267b3385a49550fa47ee33d0f428e5833a59d8224aa4eb2b0251841c58acc1ca446ef1b13d258c5b861045f042f7ca13e8a27db7253f4202753c607 SHA512 22a65b06d81651455ecd9690bc5c6d4c87858bf912eb491dde16650a3692408ca95a1d42d82204e67509f4e685651b5b2b2537b5db0891b7ca6933bddd616d16
diff --git a/dev-python/line_profiler/line_profiler-3.5.1.ebuild b/dev-python/line_profiler/line_profiler-3.5.1.ebuild
deleted file mode 100644
index d367af0ab0f5..000000000000
--- a/dev-python/line_profiler/line_profiler-3.5.1.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
-# force it to match scikit-build
-CMAKE_MAKEFILE_GENERATOR=ninja
-
-inherit cmake distutils-r1
-
-DESCRIPTION="Line-by-line profiler"
-HOMEPAGE="
- https://github.com/pyutils/line_profiler/
- https://pypi.org/project/line-profiler/
-"
-SRC_URI="
- https://github.com/pyutils/line_profiler/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-SLOT="0"
-LICENSE="BSD"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- dev-python/ipython[${PYTHON_USEDEP}]
-"
-# technically, the package claims to support non-scikit-build build
-# but it's clearly unmaintained and broken at the moment
-BDEPEND="
- dev-python/cython[${PYTHON_USEDEP}]
- dev-python/scikit-build[${PYTHON_USEDEP}]
- test? (
- dev-python/coverage[${PYTHON_USEDEP}]
- dev-python/ubelt[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- cmake_src_prepare
- distutils-r1_src_prepare
-}
-
-python_test() {
- cd tests || die
- epytest
-}