summaryrefslogtreecommitdiff
path: root/dev-python/line_profiler
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-06 15:22:56 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-06 15:22:56 +0100
commit564f8bfdb74759f8e95ec50a16419425e8ba8f25 (patch)
tree2738b2fbae70ae5b251665eb6da25467f5db050d /dev-python/line_profiler
parent9b81b8a93760fc1c7d79561adbd7a62c82f334db (diff)
gentoo auto-resync : 06:08:2023 - 15:22:56
Diffstat (limited to 'dev-python/line_profiler')
-rw-r--r--dev-python/line_profiler/Manifest2
-rw-r--r--dev-python/line_profiler/line_profiler-4.0.3.ebuild5
2 files changed, 4 insertions, 3 deletions
diff --git a/dev-python/line_profiler/Manifest b/dev-python/line_profiler/Manifest
index 2c35b581533b..4774160c0b58 100644
--- a/dev-python/line_profiler/Manifest
+++ b/dev-python/line_profiler/Manifest
@@ -1,3 +1,3 @@
DIST line_profiler-4.0.3.gh.tar.gz 63873 BLAKE2B b34baa89d6625e0887823a44b89fc1b5c3a069ba5d160b959fd435080cfa64e68f693a03e3ed2741efc6d7ca71a60ac0b0e43bd8ba3101089a4e3d0d6c88303e SHA512 3f7734e3651588b1d40df0836d8c93384541b6a010e70becc419101377ac90374fc8f202b927b42ca4aec3e030d9ed52f4955f9fcae3c8d0396f96e21a29eeac
-EBUILD line_profiler-4.0.3.ebuild 801 BLAKE2B 0e7945089e75e56878bf613764cbf906abb5fefcd60ecfc06f0ea256a62b7e24661c097d2f3935a9fe48d2499e25abd4b1407bdc2332bd188100d1659fab0bd8 SHA512 dbbccdc389788313a9257ff4f746103ce6ef2fcff241c663b4dc0d657f49f927427aa9968fca590adff3448930b83749b4255b6b3998dc2860fdd60ad0662419
+EBUILD line_profiler-4.0.3.ebuild 849 BLAKE2B a1e40e229a6ea91eae3396d47bc956e27faa2af3ef85045b69de2bdacb0d9b398b62bddd6f12bf2e530a2c702f295b6ec5b18f2e0fa8f65afa07c417e45deb9a SHA512 ba61d0598e73ab178cefdd7ea354eae53eea4cf130bbe94e0a776a3c880c98a9ff60403c28071e24b08cfc1d76403dd76f2cf89707ff6e0fcc93f99384d9ed4e
MISC metadata.xml 775 BLAKE2B de65859e8267b3385a49550fa47ee33d0f428e5833a59d8224aa4eb2b0251841c58acc1ca446ef1b13d258c5b861045f042f7ca13e8a27db7253f4202753c607 SHA512 22a65b06d81651455ecd9690bc5c6d4c87858bf912eb491dde16650a3692408ca95a1d42d82204e67509f4e685651b5b2b2537b5db0891b7ca6933bddd616d16
diff --git a/dev-python/line_profiler/line_profiler-4.0.3.ebuild b/dev-python/line_profiler/line_profiler-4.0.3.ebuild
index 2cf016dcb0a6..bb034b04c80c 100644
--- a/dev-python/line_profiler/line_profiler-4.0.3.ebuild
+++ b/dev-python/line_profiler/line_profiler-4.0.3.ebuild
@@ -5,7 +5,7 @@ EAPI=8
DISTUTILS_EXT=1
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..11} )
inherit distutils-r1
@@ -26,8 +26,9 @@ KEYWORDS="~amd64 ~x86"
RDEPEND="
dev-python/ipython[${PYTHON_USEDEP}]
"
+# <cython-3: https://bugs.gentoo.org/911735
BDEPEND="
- dev-python/cython[${PYTHON_USEDEP}]
+ <dev-python/cython-3[${PYTHON_USEDEP}]
test? (
dev-python/coverage[${PYTHON_USEDEP}]
dev-python/ubelt[${PYTHON_USEDEP}]