summaryrefslogtreecommitdiff
path: root/dev-python/line_profiler
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-24 23:59:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-24 23:59:54 +0000
commit401101f9c8077911929d3f2b60a37098460a5d89 (patch)
treec2bef4719f6787550f0916aeaa8f4f403a9296af /dev-python/line_profiler
parent4cbcc855382a06088e2f016f62cafdbcb7e40665 (diff)
gentoo resync : 25.03.2022
Diffstat (limited to 'dev-python/line_profiler')
-rw-r--r--dev-python/line_profiler/Manifest2
-rw-r--r--dev-python/line_profiler/line_profiler-3.5.0.ebuild50
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/line_profiler/Manifest b/dev-python/line_profiler/Manifest
index 7efc5db282f0..d159a5dfb7f3 100644
--- a/dev-python/line_profiler/Manifest
+++ b/dev-python/line_profiler/Manifest
@@ -1,5 +1,7 @@
DIST line_profiler-3.3.1.gh.tar.gz 56700 BLAKE2B 030c0fc742a6773ebb55a54a3c21d3d5e5d6d5d258a2c3cd2071ff93917411b65e100bfc6549d9c60d9a7c361c53b291d8b81538acaf5b83665c04129d25bc02 SHA512 8a3704a6df2abe71283cb2da23b738932c6f4b42aedcdefda0d318fd4b894d56831a855c4be4430657308530a04d1e96b0e15a60edca06621bdd5370c0bf9911
DIST line_profiler-3.4.0.gh.tar.gz 49076 BLAKE2B 1fa2d7462913b21b5c3d69be64492fd5002d10c6c454cb3129860e4156cf04fbbd839b140f229b586ff9f0b195baae435bc461c4bab1405c38da49bf348827c3 SHA512 79a6e71ec083aacbc95fab5e044a2a38119bced505e5b9720288e32103773dc64a8bbbf6c2c7913b7b5057420cb31c3943cc1dce2d7d029df82b6b59e451c357
+DIST line_profiler-3.5.0.gh.tar.gz 51142 BLAKE2B 1dade129a8913f6fe42fcd646c1f8850b5a948bad476755dd54bf04815e293508d77b9160157623a6060a864722c81466690722b79a603bba9b7651ba3e7e25d SHA512 4c797bb9990e77a5ef8cb38113fe28c4925a631ca8f034f33fe2aeeeb77bf9b24cfc1fb6217ddec07b767a2dec325f388e402ca38da43790f58c644a4a147a75
EBUILD line_profiler-3.3.1.ebuild 1072 BLAKE2B 6b412fbfd938cf1a646c17aed4cf97a308e8d5af97791ffed24ecdabb3b93e3fdf5f7da2b866cb2023dda6bfeddada7bbf79c9f7d408f5369f383b4924926f48 SHA512 12d0eb3477bd386b3394ad9acb65c5dd120fa67fc8928072aa5da84758a72dd4e11e2c7e3dd69873d6a45a2748709cadcd875c7b92747997d8ca18e7367b8a62
EBUILD line_profiler-3.4.0.ebuild 1073 BLAKE2B 171915773afd9869541a1be2f2e32136d30012501fcc264ced89f882d4898e4d65f013277a75c409c42d469fba5e3e957dee496122fd7d6d72025355e729d6bf SHA512 f450adefc1c623201ee85cb3beac0a877cd1b30706dd829cf3b5452e5457a18e3fcf9bf1729d4ca7e3a9e7d516fd7bf4ba17cbe9b2f56448a4ec9a0da34ba0be
+EBUILD line_profiler-3.5.0.ebuild 1004 BLAKE2B 3ae5eb967e59fa65ad0b2d7e7c17f0d6a20f1e768d80eeeb817474e1d3f9095370fa8b48c78d1c05c8c195748d87202094c58eb805dc6bfdc10a4da384610d46 SHA512 bbc8f218be66e5c0d8dc7f206901892aa516d37fdf14b301c3b335d5ac0f3041eaa092642223b1b143544f4bb59aebcbf98a6515faa249023726734ed763585b
MISC metadata.xml 775 BLAKE2B 6d817146b4f2379141f3def2ab8cb2d69f40e1e7645e714c09ad30a425d14c85c50749ffe2c4d6dec9bf146e294caaf8a1647d2a15d672667932ca7543d0df59 SHA512 745e91051af76df1a7344923dfdfad748fc11bf663c60f3c83a5d434ebfeb218ccc91a314244008bf6a39a4be77b3b3c5457739e1102ba188ddf7c8203b75695
diff --git a/dev-python/line_profiler/line_profiler-3.5.0.ebuild b/dev-python/line_profiler/line_profiler-3.5.0.ebuild
new file mode 100644
index 000000000000..a631bb642adf
--- /dev/null
+++ b/dev-python/line_profiler/line_profiler-3.5.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+# force it to match scikit-build
+CMAKE_MAKEFILE_GENERATOR=ninja
+
+inherit cmake distutils-r1
+
+DESCRIPTION="Line-by-line profiler"
+HOMEPAGE="
+ https://github.com/pyutils/line_profiler/
+"
+SRC_URI="
+ https://github.com/pyutils/line_profiler/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/ipython[${PYTHON_USEDEP}]
+"
+# technically, the package claims to support non-scikit-build build
+# but it's clearly unmaintained and broken at the moment
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/scikit-build[${PYTHON_USEDEP}]
+ test? (
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/ubelt[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ cmake_src_prepare
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ cd tests || die
+ epytest
+}