summaryrefslogtreecommitdiff
path: root/dev-python/license-expression
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-02 11:00:10 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-02 11:00:10 +0000
commit4c506c69909bdb43fda5e36c79b165e404d3b86b (patch)
treeb0f9d49fd462021c82f6ebbbbafb92e1a0eae3da /dev-python/license-expression
parent81f73a84efe20818880d8c52c55a3bd067115b06 (diff)
gentoo auto-resync : 02:12:2023 - 11:00:10
Diffstat (limited to 'dev-python/license-expression')
-rw-r--r--dev-python/license-expression/Manifest2
-rw-r--r--dev-python/license-expression/license-expression-30.2.0.ebuild34
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/license-expression/Manifest b/dev-python/license-expression/Manifest
index 65ed55c4948b..1468e731fe89 100644
--- a/dev-python/license-expression/Manifest
+++ b/dev-python/license-expression/Manifest
@@ -1,3 +1,5 @@
DIST license-expression-30.1.1.gh.tar.gz 165700 BLAKE2B b79dcb1966658ceb78fcc8a335c90d08c1aaf1933251a14cfa3caf97bbacea9090103727811b654c7c013b24f97ca0529c1589cef5ea096079c33df761ad2ebd SHA512 83a683b7479088f5f4b0d4c4854d17150dd07b60231ebcea5a299e0a3109a833477f86b3dbb2f7d7da932f610fc0489fd019b823ad6e0554f7cc372dfcabdbc1
+DIST license-expression-30.2.0.gh.tar.gz 170391 BLAKE2B 38e934fa4c442b797be34b4431955bba5eae589247288f827753fdd167177839faac057448422fe1176127b0c96734c19c185c11814dc7d7765538b3d4184bd1 SHA512 13a9dea381088d95421aca8d096c54e9537bd0671000a21067257d01ced28a5c778bf8adff3d6e83ed89559ed62a0d08ccf98c88c0974c913b199f68d0a4336c
EBUILD license-expression-30.1.1.ebuild 797 BLAKE2B a59f4c6684adb877b19f8f86cc61212518fb3754838fa07b872d2535e1e734d1c05d2bc59dd55c385788dfc3ed80769afc7eea62f996b3690c033f203a19e84e SHA512 ccd5d6e8ec196fac12b0876662b0b395c40b2e13ea43d735b68beba4424424d9c6138d32f314ad6a4cd65cc2d66dc8bcd36e4d596eeea66c6b21a5af5971cf4c
+EBUILD license-expression-30.2.0.ebuild 805 BLAKE2B 29a990f046dd501aedc571cdb59610a2205e9e63e9b4b7d7092db7c131c5b84e133b17902645df933418fbc71426a2692f213380fd468dd2cb39d3dfc888f125 SHA512 0554c22015f12075c5b71f84b3e38551089f20f937d7f5bf448f51af6b8f9934569e0b3f4f1cfa8b9ae46c4647b3b11f0b628b0261370119e5dfec0046a9730c
MISC metadata.xml 387 BLAKE2B 52d862f7ede77b8ab90dbd9ed2949f1c4a2b289458cff0f2e7042bf43be07b7d7e63ff94f0a10aa1db41027b3441be721656def8d59ba54155d3226e4bd30b57 SHA512 7ba89c3d94ef921fad190a85655d032a7e3a0c5794d0957c3a30ff73c75b717e87517f5f2547408426479d646ac3d157f7e659d66a18d4081689b6b41136b268
diff --git a/dev-python/license-expression/license-expression-30.2.0.ebuild b/dev-python/license-expression/license-expression-30.2.0.ebuild
new file mode 100644
index 000000000000..570871137320
--- /dev/null
+++ b/dev-python/license-expression/license-expression-30.2.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Parse, compare, simplify and normalize license expressions"
+HOMEPAGE="
+ https://pypi.org/project/license-expression/
+ https://github.com/nexB/license-expression/
+"
+SRC_URI="
+ https://github.com/nexB/license-expression/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/boolean-py-4.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools-scm-4[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}