summaryrefslogtreecommitdiff
path: root/dev-python/libtmux/libtmux-0.14.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-06 20:10:31 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-06 20:10:31 +0100
commit944b3df0f275eea0fd7808913d72a0b280df0c33 (patch)
treeec33697fafd5ce7028b7619baef7a6d27bb74362 /dev-python/libtmux/libtmux-0.14.0.ebuild
parent7e17b5aabc330abb894f2b90bef0e3fcbcd180d2 (diff)
gentoo auto-resync : 06:08:2022 - 20:10:30
Diffstat (limited to 'dev-python/libtmux/libtmux-0.14.0.ebuild')
-rw-r--r--dev-python/libtmux/libtmux-0.14.0.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/libtmux/libtmux-0.14.0.ebuild b/dev-python/libtmux/libtmux-0.14.0.ebuild
new file mode 100644
index 000000000000..be24d300e9a1
--- /dev/null
+++ b/dev-python/libtmux/libtmux-0.14.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="python api for tmux"
+HOMEPAGE="https://libtmux.git-pull.com/"
+SRC_URI="
+ https://github.com/tmux-python/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+RDEPEND="
+ >=app-misc/tmux-3.0a
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/twine[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ libtmux/pane.py::libtmux.pane.Pane.send_keys
+)
+
+python_prepare_all() {
+ local issues="https://github.com/tmux-python/libtmux/issues/"
+ sed -r -i "s|:issue:\`([[:digit:]]+)\`|\`issue \1 ${issues}\1\`|" CHANGES || die
+ rm requirements/doc.txt || die
+
+ # increase timeouts for tests
+ sed -e 's/0.01/0.1/' -i tests/test_test.py || die
+
+ distutils-r1_python_prepare_all
+}