summaryrefslogtreecommitdiff
path: root/dev-python/libsass
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-07 12:53:51 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-07 12:53:51 +0000
commit02814fd00146251691678aa18d9937665c677086 (patch)
tree5408cf868c128b241de5bab0f807058065bea7c8 /dev-python/libsass
parent79713e75fcc5c5cb55d1b1beac008683b57c8805 (diff)
gentoo auto-resync : 07:01:2024 - 12:53:51
Diffstat (limited to 'dev-python/libsass')
-rw-r--r--dev-python/libsass/Manifest2
-rw-r--r--dev-python/libsass/libsass-0.23.0.ebuild62
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/libsass/Manifest b/dev-python/libsass/Manifest
index a36d17c1a602..1e7aa4ab5a48 100644
--- a/dev-python/libsass/Manifest
+++ b/dev-python/libsass/Manifest
@@ -1,3 +1,5 @@
DIST libsass-python-0.22.0.gh.tar.gz 55135 BLAKE2B 8495462fa8e6a68bf73ecdf68771c577bad1affa1121c1781dac41c912aae731df88c2b1d1a4ef363e50a98ff1b471e7c45562faa6f2425e8ec5f47f9cf76c6c SHA512 13914b60fe19fc70d197a948a2bc83f7646e4acaa45caed6df68bf2eb10e0a7ef811cdbbcc7a4338f9c1433cba8e316146c20072dc4ff34f51e094ead1bfdcd7
+DIST libsass-python-0.23.0.gh.tar.gz 54783 BLAKE2B b2113d295370391c6b92c2561873cc1c58c3acdcc5c4adb6c50e717bb963bbf5d4e29e97290e2b4743508c0f1a73be373233205a79c31b6f6a0262559adcf924 SHA512 fb0836cce26ef8cdfb90cb50842e66f83ed47d06327272a49db3f2cf4b7f1bc29560d0126f00ff13db626d0624ff154c342a0f2433802d4c1b582b8d74a50337
EBUILD libsass-0.22.0-r1.ebuild 1397 BLAKE2B e4a6790307f98d5bfec3c8e818ef5eb933835705f50f9e24ac99df73e516e813cf3216e89fc935d4faf479e192ccba7a4ce90a027205fcfa8b82a885596afa8d SHA512 cd14b7d92d5dc3f5486aba0a16d6ebab9b24487f222fb0a1ca7b6bf780195807f6cd706a245effe03fd267ae1c34564765175b5b341387b0f6194443f6eda4db
+EBUILD libsass-0.23.0.ebuild 1351 BLAKE2B ea9d9a9e073dcf43047375dca79add6e687b960840c959cbd73e585af8021411c1585dc7d2f400f2ee72c97ffcdbf6a59fb77770834172c7f4ab43abfb644f62 SHA512 7dbaa3b16712c375090c6d18933f8ea453c251c3bd44544a82f00b6e92b3d55a08d46cb8bad5f3180716a859302465eb3b44b437c8eebb3707ef3c694f8ce6d8
MISC metadata.xml 489 BLAKE2B 81f6227a151dbe09e04bc80d25fa9140a08e81d71c531ccf856073c799dbfcb28a0052c5ca8875eb0b52ac93c49098325c02502b7c8ca38e5185601187afe587 SHA512 110e06d1903247bfb00db8cce722d7654c528257e61bfb8281aad749fed6ef385b4aaee3f87f17a8c75eeeafae8f1818d86273900874a776dfa321254b63b67f
diff --git a/dev-python/libsass/libsass-0.23.0.ebuild b/dev-python/libsass/libsass-0.23.0.ebuild
new file mode 100644
index 000000000000..a076bac3b66a
--- /dev/null
+++ b/dev-python/libsass/libsass-0.23.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P=libsass-python-${PV}
+DESCRIPTION="A straightforward binding of libsass for Python"
+HOMEPAGE="
+ https://github.com/sass/libsass-python/
+ https://pypi.org/project/libsass/
+"
+SRC_URI="
+ https://github.com/sass/libsass-python/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+DEPEND="
+ >=dev-libs/libsass-3.6.5
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ test? (
+ dev-python/PyQt5[testlib,${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+ export SYSTEM_SASS=1
+ # https://bugs.gentoo.org/881339
+ # the package is applying C++ flags to C sources
+ sed -i -e "s:'-std=gnu++0x',::" -e "s:'-lstdc++'::" setup.py || die
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # probably broken by removal of sassc
+ sasstests.py::SasscTestCase::test_sassc_stdout
+ # skip the pip tests because they need an internet connection
+ # not relevant for gentoo anyway
+ sasstests.py::DistutilsTestCase::test_build_sass
+ sasstests.py::DistutilsTestCase::test_output_style
+ )
+
+ epytest sasstests.py
+}