summaryrefslogtreecommitdiff
path: root/dev-python/libpillowfight
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-07 13:16:39 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-07 13:16:39 +0100
commite91a1aaa5ec8fab37f0fd082ac6024d41c6651e2 (patch)
treeee7587dfd365faadd9b297d595c31368bf94f9ca /dev-python/libpillowfight
parent2d446203bcf1a0db08e99abca43513d246dfa73d (diff)
gentoo resync : 07.04.2018
Diffstat (limited to 'dev-python/libpillowfight')
-rw-r--r--dev-python/libpillowfight/Manifest2
-rw-r--r--dev-python/libpillowfight/libpillowfight-0.2.3.ebuild28
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/libpillowfight/Manifest b/dev-python/libpillowfight/Manifest
index a0855ec3c808..45b7d9f96ef9 100644
--- a/dev-python/libpillowfight/Manifest
+++ b/dev-python/libpillowfight/Manifest
@@ -1,3 +1,5 @@
DIST libpillowfight-0.2.2.tar.gz 23125494 BLAKE2B b9620b0e574869d1efcc9449e09f281a5d2611ec15f144ee24b385b5f6f693f037c844904f0abc715d49125df7d1a27d6c433aed83b33371b3f07310be8288db SHA512 76dcaf9105b4dbbe427851d794e92ba023453e2d750ecdd4e3feb864534f9d99adb562b719b7c9af299ae16c0778b510ab96b4997cf9bcc6ea4c6f8f7471ae8a
+DIST libpillowfight-0.2.3.tar.gz 14567996 BLAKE2B 2b3f289f8a86b2b50004adb158dd992fd18bdaac17f21de6f3a9493c8a54a869a788a71d71257845de43f6fa048789944d1b49fd2da190919dad18db7f7d70d0 SHA512 a1098776157a2f552c84bc0e36d8d69ec59e2405bb351253ebf4c5c241fe1ce0de01fac20b4240d010d555afaf4d2c269adce8c89894ab301e14f8c891a744da
EBUILD libpillowfight-0.2.2.ebuild 676 BLAKE2B 07c3d9097cd838705c06523c4c19b8314b822ce7427c011da9760b2b033dfb0aea8202ae3cbe00546cdb20074f121b607f66ceff7d712c4e24e39d89c22433eb SHA512 8919455d801ce8da7f49b41728d3dd41362b3669e3a23a57b3381e6a97011f3e5ddd045b3c5b59bc7fa08b1f02634076c8c288ce9d2455874cd1b672079fb46b
+EBUILD libpillowfight-0.2.3.ebuild 811 BLAKE2B d3cb69760775fb5270b938ad5c151e4439efcf57727855075bdc6de743bc615cfd5be22d15b3975197df3b6bce70e412111cd6b6703ca7e09351bbede63a7547 SHA512 fc2a2d2d5c6f35c0737da76ab52172ff3fd387be38948890111c1f680325d3d315ec92b70097a258068fb15e1663e1c9a564801e334f6f4dfec2e44e78994bd9
MISC metadata.xml 349 BLAKE2B 4b7c076969b0b1a899de7615bea08f02595e340b4ec1228e630d8feafca7709693993ac48dc3cac91ab912cb1c41fa13dac818e598eec4bfb8d928d385484b98 SHA512 5934060618b194c844776072f78ac15400fbee4629595a8c3ed60acf30b4ffd9cfed4dfcd9b263101842be197a1491daeb3e929bdd924839c17819b185ae7578
diff --git a/dev-python/libpillowfight/libpillowfight-0.2.3.ebuild b/dev-python/libpillowfight/libpillowfight-0.2.3.ebuild
new file mode 100644
index 000000000000..72af33a9a741
--- /dev/null
+++ b/dev-python/libpillowfight/libpillowfight-0.2.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Small library containing various image processing algorithms"
+HOMEPAGE="https://github.com/openpaperwork/libpillowfight"
+SRC_URI="https://github.com/openpaperwork/libpillowfight/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/pillow[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ sed -e "/'nose>=1.0'/d" -i setup.py || die
+ distutils-r1_python_prepare_all
+
+ # Upstream Makefile requires git checkout
+ echo "#define INTERNAL_PILLOWFIGHT_VERSION \"${PV}\"" > src/pillowfight/_version.h || die
+}