summaryrefslogtreecommitdiff
path: root/dev-python/libcloud
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /dev-python/libcloud
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'dev-python/libcloud')
-rw-r--r--dev-python/libcloud/Manifest4
-rw-r--r--dev-python/libcloud/libcloud-2.8.2.ebuild50
-rw-r--r--dev-python/libcloud/libcloud-3.0.0.ebuild50
3 files changed, 104 insertions, 0 deletions
diff --git a/dev-python/libcloud/Manifest b/dev-python/libcloud/Manifest
index 6c2e86f7dcf1..f2142f1be839 100644
--- a/dev-python/libcloud/Manifest
+++ b/dev-python/libcloud/Manifest
@@ -1,3 +1,7 @@
DIST apache-libcloud-2.3.0.tar.bz2 1370556 BLAKE2B 14c6604d190d63f9049de2034b487cd7bb314add399339cac7a46dcbfea339497ede0d8058fd29dab43d53a45637fc5e60c71a5079fff6f45ed5023721eb68f2 SHA512 673c5b7b12f4510f2b43ea8199fab1e3f7ded62423d7d67301f5e3448c78750bc898c494a33d033844acf94bc292582371e9ac02ce1db6f4443a3966ef9fd0e8
+DIST apache-libcloud-2.8.2.tar.bz2 1559425 BLAKE2B 86baff68dae874ee9569646ac24831858784d8323dcbff5036ed0f26afdd47d859b68592d74084844f4b7d232c25f7a99d84fddbfcba54df6939f426203e59ff SHA512 9834cd54df11a27876bdc70c85e7d9e3063cd2639d9f19ccd17ec7841fc0e8db6fbc2d562320656a7db4edbe5a940e8562c929a21203757fabe78a4b48d89367
+DIST apache-libcloud-3.0.0.tar.bz2 1609684 BLAKE2B cac9f42a2e73c8903d9b29c8e39d0d16d56138adbe2bdf60abb52c02fbd41f8fbe063238a09ce27b2b921eb082a82881f31211dbcb864e183c3f582fdb75858a SHA512 17569ce820fc5bc792a23636c8d2cc2067059425217b9b0dd90fcba40a5f347dca66531201c458b12d61caf3854355b6a7dca7efc17b05fbab364c8d2bdc2405
EBUILD libcloud-2.3.0.ebuild 1014 BLAKE2B ce793197b34426ea97c51c9282dc80e5e1752a9b097dfb8bb18e70b73617c47ee6da4bf3937b467d41c37a07f9c7a3670a01d70bddef36b77096cd47c05327a9 SHA512 917f4baab209452452b64ef4d28eb4c5e6485250dd5195a2ba1cbc24c330c8ac6539139f2221c6b33168966d92737d1d38bb08ed46094531dcab0cebdecfdb02
+EBUILD libcloud-2.8.2.ebuild 1044 BLAKE2B 0de7d4e0d6655325b5b5aad9935e04c85b3402fd67286d00724b38d683ad4ba8ed293f05689a63389375cf467941debd8eaf66b504ad81de572963a1300835a4 SHA512 b34c4fae3906d937f1a7b096554866f5574eee3ab81e70181ea568b4f7331600b16437e373a2c783ea1612d0e3d7708ff5dcf00a7ce68b75019cec9e422de79a
+EBUILD libcloud-3.0.0.ebuild 1042 BLAKE2B 681bdc24f534ae3096275c77add0f5a53ac8e91b584969e287cdc9f7672abe4d02d539ed4f968d1c647add33c89f4336b6b117af0c356c3416bf74c396cb3771 SHA512 2054b523a38c7ab0e9740d7904569a7d046e5bfd68f5ad8f177e8c7bae15678a264f8c564c3bb0ea743b7e3ee84f7037e74a4687363de345dba60f6955161c92
MISC metadata.xml 167 BLAKE2B e4dadf27fd344484f2bccb5b904909c89aac568c32e5b3c44bdf139eacefd4b4fae74419f503d2b7da0dccc1b68ba05d777d11292c0f89270d1ac5c9c703e8ca SHA512 7c8decb24ee3a850e38186cf3c7f8933a28017426806870ad6ef9ceb2533be147a2681fc789b535a81cb528af8c29d90d3006e4f250aee23bd7dea4561294e33
diff --git a/dev-python/libcloud/libcloud-2.8.2.ebuild b/dev-python/libcloud/libcloud-2.8.2.ebuild
new file mode 100644
index 000000000000..b8b53b82c69d
--- /dev/null
+++ b/dev-python/libcloud/libcloud-2.8.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_REQ_USE="ssl(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Unified Interface to the Cloud - python support libs"
+HOMEPAGE="https://libcloud.apache.org/"
+SRC_URI="mirror://apache/${PN}/apache-${P}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples test"
+
+RDEPEND="
+ >=dev-python/requests-2.5.0[${PYTHON_USEDEP}]
+
+"
+BDEPEND="${RDEPEND}
+ test? (
+ dev-python/lockfile[${PYTHON_USEDEP}]
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-2.6.1[${PYTHON_USEDEP}]
+ )"
+
+S="${WORKDIR}/apache-${P}"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ if use examples; then
+ mkdir examples || die
+ mv example_*.py examples || die
+ fi
+
+ # needed for tests
+ cp libcloud/test/secrets.py-dist libcloud/test/secrets.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/libcloud/libcloud-3.0.0.ebuild b/dev-python/libcloud/libcloud-3.0.0.ebuild
new file mode 100644
index 000000000000..3bab3980f0fd
--- /dev/null
+++ b/dev-python/libcloud/libcloud-3.0.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_REQ_USE="ssl(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Unified Interface to the Cloud - python support libs"
+HOMEPAGE="https://libcloud.apache.org/"
+SRC_URI="mirror://apache/${PN}/apache-${P}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="examples test"
+
+RDEPEND="
+ >=dev-python/requests-2.5.0[${PYTHON_USEDEP}]
+
+"
+BDEPEND="${RDEPEND}
+ test? (
+ dev-python/lockfile[${PYTHON_USEDEP}]
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-2.6.1[${PYTHON_USEDEP}]
+ )"
+
+S="${WORKDIR}/apache-${P}"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ if use examples; then
+ mkdir examples || die
+ mv example_*.py examples || die
+ fi
+
+ # needed for tests
+ cp libcloud/test/secrets.py-dist libcloud/test/secrets.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}