summaryrefslogtreecommitdiff
path: root/dev-python/libcloud
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /dev-python/libcloud
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'dev-python/libcloud')
-rw-r--r--dev-python/libcloud/Manifest4
-rw-r--r--dev-python/libcloud/libcloud-1.5.0.ebuild54
-rw-r--r--dev-python/libcloud/libcloud-2.3.0.ebuild1
3 files changed, 1 insertions, 58 deletions
diff --git a/dev-python/libcloud/Manifest b/dev-python/libcloud/Manifest
index 83db5138c6af..4af53b828395 100644
--- a/dev-python/libcloud/Manifest
+++ b/dev-python/libcloud/Manifest
@@ -1,5 +1,3 @@
-DIST apache-libcloud-1.5.0.tar.bz2 1258553 BLAKE2B 9cad0f61ab8505deea99c15022da92caf24295480d16bedf9c735c1117a055c94162cdcb331734c572f375de3ba10b499d5ed46a5a11f1e634d272e69748ef79 SHA512 91c10d164f56c9f75c6e5633802c3cf31046ab7a3ae554b73310b1da2d882ac1f8e90aaf3462db57ac0949dfd66cb840ec8fc6e6b79c46128668f13183d47b30
DIST apache-libcloud-2.3.0.tar.bz2 1370556 BLAKE2B 14c6604d190d63f9049de2034b487cd7bb314add399339cac7a46dcbfea339497ede0d8058fd29dab43d53a45637fc5e60c71a5079fff6f45ed5023721eb68f2 SHA512 673c5b7b12f4510f2b43ea8199fab1e3f7ded62423d7d67301f5e3448c78750bc898c494a33d033844acf94bc292582371e9ac02ce1db6f4443a3966ef9fd0e8
-EBUILD libcloud-1.5.0.ebuild 1181 BLAKE2B 14dc4041bb03c683f9abc6464d0d6d93cead56ae56f45f90865b2d6416ec282843f2438aa147eaeef61f080f18ca486efd969505d3b78d86ac20a898f34d7fb1 SHA512 c3a4e4d36d9c34ea552a093109701ad1b41e0ecaa9f20c0192aabe4fd260c554505c98da1c65a3d3856da89266f2418107610098cdde8ac310ce1b7c6fd938d0
-EBUILD libcloud-2.3.0.ebuild 1115 BLAKE2B 69582e0f8a0804734ac4e1e8c4e5ab09340ba0bf2bcab70ceedc4f6e8abac082af5a6a62241c3024020c54d6fe5ee7d1b4c7defd3dc8b2d04bedf763fb420900 SHA512 efe6a44bb7fc595afc980abf9607684136a2187be0a554ab844016a53be3fc70fce52ebea10133a3b588bc2b7f648328c2a1a69799c6bb2ae093f6232caae33b
+EBUILD libcloud-2.3.0.ebuild 1014 BLAKE2B ce793197b34426ea97c51c9282dc80e5e1752a9b097dfb8bb18e70b73617c47ee6da4bf3937b467d41c37a07f9c7a3670a01d70bddef36b77096cd47c05327a9 SHA512 917f4baab209452452b64ef4d28eb4c5e6485250dd5195a2ba1cbc24c330c8ac6539139f2221c6b33168966d92737d1d38bb08ed46094531dcab0cebdecfdb02
MISC metadata.xml 240 BLAKE2B 41e6a4d9da33dab2decc5ff419924f382a8f64d27a81fdb97576db8c6cf125be95911747946ec8be1b453f56617fef1084f5947f84b50a8db419d46df2ae8a0f SHA512 9c23321eaa853f851bf00195ea64ac2ba093e516f9b57855ee5aa58fbb1988130c9f0c17c2a9ce9fae4ee033e0a28a70c868e0f5acdfa1dd316ab533c5279d59
diff --git a/dev-python/libcloud/libcloud-1.5.0.ebuild b/dev-python/libcloud/libcloud-1.5.0.ebuild
deleted file mode 100644
index e44f1f4a4793..000000000000
--- a/dev-python/libcloud/libcloud-1.5.0.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-# py3 dropped due to failing tests once lockfile installed
-PYTHON_COMPAT=( python3_6 )
-PYTHON_REQ_USE="ssl(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Unified Interface to the Cloud - python support libs"
-HOMEPAGE="https://libcloud.apache.org/"
-SRC_URI="mirror://apache/${PN}/apache-${P}.tar.bz2"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="examples test"
-
-RDEPEND=""
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/lockfile[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/backports-ssl-match-hostname[${PYTHON_USEDEP}]' python2_7 pypy)
- )"
-
-# Known test failures
-RESTRICT="test"
-
-S="${WORKDIR}/apache-${P}"
-
-python_prepare_all() {
- if use examples; then
- mkdir examples
- mv example_*.py examples || die
- fi
- distutils-r1_python_prepare_all
-}
-
-src_test() {
- cp libcloud/test/secrets.py-dist libcloud/test/secrets.py || die
- distutils-r1_src_test
-}
-
-python_test() {
- esetup.py test
-}
-
-python_install_all() {
- use examples && local EXAMPLES=( examples/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/libcloud/libcloud-2.3.0.ebuild b/dev-python/libcloud/libcloud-2.3.0.ebuild
index d72292e9e812..5820bf095b9e 100644
--- a/dev-python/libcloud/libcloud-2.3.0.ebuild
+++ b/dev-python/libcloud/libcloud-2.3.0.ebuild
@@ -22,7 +22,6 @@ DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
test? (
dev-python/mock[${PYTHON_USEDEP}]
dev-python/lockfile[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/backports-ssl-match-hostname[${PYTHON_USEDEP}]' python2_7 pypy)
)"
# Known test failures