summaryrefslogtreecommitdiff
path: root/dev-python/lesscpy/lesscpy-0.15.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-17 19:04:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-17 19:04:28 +0100
commit514d1bbe260df2521fe60f1a3ec87cfcfde1a829 (patch)
tree555c194dbeb0fb2ac4ad3cde7c0f6a80fd330ce2 /dev-python/lesscpy/lesscpy-0.15.0.ebuild
parent4df3bf9762850b34cd1ead5c80374d1a0fc3362e (diff)
gentoo resync : 17.07.2021
Diffstat (limited to 'dev-python/lesscpy/lesscpy-0.15.0.ebuild')
-rw-r--r--dev-python/lesscpy/lesscpy-0.15.0.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/lesscpy/lesscpy-0.15.0.ebuild b/dev-python/lesscpy/lesscpy-0.15.0.ebuild
new file mode 100644
index 000000000000..355dc111b941
--- /dev/null
+++ b/dev-python/lesscpy/lesscpy-0.15.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="A compiler written in Python for the LESS language"
+HOMEPAGE="https://pypi.org/project/lesscpy/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/ply[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+
+distutils_enable_tests unittest