summaryrefslogtreecommitdiff
path: root/dev-python/leather
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
commit46eedbedafdb0040c37884982d4c775ce277fb7b (patch)
treedb33a91259730be84999e13a8d8168c799f50ac0 /dev-python/leather
parente23a08d0c97a0cc415aaa165da840b056f93c997 (diff)
gentoo resync : 20.10.2021
Diffstat (limited to 'dev-python/leather')
-rw-r--r--dev-python/leather/Manifest5
-rw-r--r--dev-python/leather/files/leather-0.3.3-fix-py3.10.patch40
-rw-r--r--dev-python/leather/leather-0.3.3-r2.ebuild51
-rw-r--r--dev-python/leather/leather-0.3.4.ebuild26
4 files changed, 28 insertions, 94 deletions
diff --git a/dev-python/leather/Manifest b/dev-python/leather/Manifest
index d392d37a0cc1..c8601bfe10a6 100644
--- a/dev-python/leather/Manifest
+++ b/dev-python/leather/Manifest
@@ -1,4 +1,3 @@
-AUX leather-0.3.3-fix-py3.10.patch 1235 BLAKE2B b71bb4d6b541ba55ca3cde388a331b69b8f93589d04e5c33c75033c9bfa63d718cfac16e1298df03ba024251618de72a0699687364daab87cfe1c9d5bbb94a42 SHA512 cfffdd293685cc0cd74b94ddef9458bdb5d63dfbfad976c097413111e336ac879c07e67226c27f5fdf4b121fe23005eb38f2de4f59d07a94c3930b01f7163eeb
-DIST leather-0.3.3-src.tar.gz 40522 BLAKE2B 3c7e6a48615751b310b7f066f2a78a2494e00256cae2ebfb4633c9389cca2477c2265fcf8c68f37733568ef729db1a5daf02ddc640bf2a60f2b39127c9a38d91 SHA512 30ea50ac6f97c55ee695b0e175a27e1e64fd17da7b0686ca8595fe0e5067932e19e59368fe6441f8f291ec52be3e597a80f8e04a3fcc0eeae33b3a5b3030e1d6
-EBUILD leather-0.3.3-r2.ebuild 1240 BLAKE2B 387ecca42ff6558fbc3cbaf99b90850cb9565ad67ac937871f883915dcd633ed69e3a49998485b40080c2a9e9dc8a27d585a8eca3ddb93f598965acadd7fff1f SHA512 bf7064a146d7e5f0efacb420bd104a7f408cc1fa6b85f4cd889b873b2b8d657af59e8e2df7e41d563fc697b1c470b840d3db22002f2b93c58b07b4cafba64eeb
+DIST leather-0.3.4.gh.tar.gz 41368 BLAKE2B a1181da5904234677290134726da33a71e0f37e6f0161beb0ec7a73efca1b2b26e973221f2f42b72fd2640ef503a8adc905273885deef212ee9d1aae6d91f804 SHA512 0547adf5d455afe9397cf9c597cc7edbcdbe25bb56e32d764c67119bfe1329d959834f2a41720adb51ec926065e044feb27f7a5e3f800c8636a22d4f96752212
+EBUILD leather-0.3.4.ebuild 659 BLAKE2B feb742b0c9b99c969c3e2c71c6618267596428158de6016564be9cfc621bbda598d623426eaa5bd29fcefb7141beb534648252c0e69df3f8bac911583eb3bb6f SHA512 55cdeb650156a7b362090837f22ee78a6f181b8f96ae47bf622c2367a56ae743050cc38e626c75050b6aa4e73c4a0147c45f34999a5d18a4eb2dcd2c6e7e9e0a
MISC metadata.xml 518 BLAKE2B 648219c9f1fc5535618ef0aa644fae01ddd4dbeeaa18abe51d6d3b78294bba210382c27ba9ff7f8ff62a649354663da3d483e46639d50b908a32993e27262ce2 SHA512 62a25d54f7de231344d7a3ddfa38f5ca145f6daa099e2a5666dc15ebee2448b2ee328d349b8a27db8d61fc2348186eae55507194338937f3bd33d1526ee0b33f
diff --git a/dev-python/leather/files/leather-0.3.3-fix-py3.10.patch b/dev-python/leather/files/leather-0.3.3-fix-py3.10.patch
deleted file mode 100644
index 8ec9e1767a4f..000000000000
--- a/dev-python/leather/files/leather-0.3.3-fix-py3.10.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-From 5dd1d3cc82d426388c66db8e3761ca2bf99a3991 Mon Sep 17 00:00:00 2001
-From: Brian <brian@quantrocket.com>
-Date: Fri, 27 Mar 2020 17:08:50 -0400
-Subject: [PATCH] import from collections.abc to suppress python 3.7 warning
-
----
- leather/series/base.py | 5 ++++-
- leather/series/category.py | 5 ++++-
- 2 files changed, 8 insertions(+), 2 deletions(-)
-
-diff --git a/leather/series/base.py b/leather/series/base.py
-index c5790e5..959e827 100644
---- a/leather/series/base.py
-+++ b/leather/series/base.py
-@@ -1,6 +1,9 @@
- #!/usr/bin/env python
-
--from collections import Iterable, Sequence, Mapping
-+try:
-+ from collections.abc import Iterable, Sequence, Mapping
-+except ImportError:
-+ from collections import Iterable, Sequence, Mapping
- from functools import partial
-
- import six
-diff --git a/leather/series/category.py b/leather/series/category.py
-index c575308..3678377 100644
---- a/leather/series/category.py
-+++ b/leather/series/category.py
-@@ -1,6 +1,9 @@
- #!/usr/bin/env python
-
--from collections import Iterable, Sequence, Mapping
-+try:
-+ from collections.abc import Iterable, Sequence, Mapping
-+except ImportError:
-+ from collections import Iterable, Sequence, Mapping
- from functools import partial
-
- import six
diff --git a/dev-python/leather/leather-0.3.3-r2.ebuild b/dev-python/leather/leather-0.3.3-r2.ebuild
deleted file mode 100644
index e2397fc3ccf7..000000000000
--- a/dev-python/leather/leather-0.3.3-r2.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python charting for 80% of humans."
-HOMEPAGE="https://github.com/wireservice/leather https://pypi.org/project/leather/"
-SRC_URI="https://github.com/wireservice/leather/archive/refs/tags/${PV}.tar.gz -> ${P}-src.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="+xml"
-
-# Other packages have BDEPEND="test? ( dev-python/leather[xml] )"
-TEST_AGAINST_RDEPEND="xml? ( dev-python/lxml[${PYTHON_USEDEP}] )"
-RDEPEND="
- ${TEST_AGAINST_RDEPEND}
- dev-python/cssselect[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
-"
-
-PATCHES=(
- "${FILESDIR}/${P}-fix-py3.10.patch"
-)
-
-distutils_enable_tests pytest
-distutils_enable_sphinx docs \
- dev-python/sphinx_rtd_theme
-
-python_prepare_all() {
- local requirements_files sed_args
-
- sed_args=(
- -e '/coverage/d'
- -e '/lxml/d' # lxml is required only when leather is used as a test dependency
- -e '/nose/d'
- -e '/tox/d'
- -e '/Sphinx/d'
- -e '/sphinx_rtd_theme/d'
- -e '/unittest2/d'
- )
-
- requirements_files+=(requirements*.txt)
- sed "${sed_args[@]}" -i "${requirements_files[@]}" || die
- distutils-r1_python_prepare_all
-}
diff --git a/dev-python/leather/leather-0.3.4.ebuild b/dev-python/leather/leather-0.3.4.ebuild
new file mode 100644
index 000000000000..0b16ba2fc747
--- /dev/null
+++ b/dev-python/leather/leather-0.3.4.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python charting for 80% of humans"
+HOMEPAGE="https://github.com/wireservice/leather https://pypi.org/project/leather/"
+SRC_URI="https://github.com/wireservice/leather/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/cssselect[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="test? ( dev-python/lxml[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/sphinx_rtd_theme