summaryrefslogtreecommitdiff
path: root/dev-python/ldap3
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-python/ldap3
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-python/ldap3')
-rw-r--r--dev-python/ldap3/Manifest2
-rw-r--r--dev-python/ldap3/ldap3-2.8.1.ebuild24
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/ldap3/Manifest b/dev-python/ldap3/Manifest
index 77598d3d08b5..ea2f79edc081 100644
--- a/dev-python/ldap3/Manifest
+++ b/dev-python/ldap3/Manifest
@@ -1,3 +1,5 @@
DIST ldap3-2.7.tar.gz 956927 BLAKE2B 7cc93df5b807745e6013b62bb35c281934cc7f191fe1ec2c117f23567a99d56557adfe924ad955e89326108136f9021f445a755670ab649d0ae571e0f986683a SHA512 52b9e8632a8d0b5cfdd801d165f72cfa78b6fa56e1c5e1b3b0b44ad1f1d695a55506b324d88af429319bc9b7b2a5d67d8f0eb6b7c305aa06a7ed9fec8aedbd94
+DIST ldap3-2.8.1.tar.gz 961648 BLAKE2B d6cbc52512efbe4f6fe5e7d19ee2ce1af3e03a8d6d08d2235eeff0f00c61fd12583c4b9fb452206ba161961c3438d109fa106a50a0edc858c24f5cd6261b2561 SHA512 f37e76e1008c990290285a757def6fe70e227393fbbdf84eb1130d5fdfd17db724c544848cc424ca7831f8cc9e8d25407fc139981ebd10818064f588adbafebf
EBUILD ldap3-2.7.ebuild 614 BLAKE2B a02ecf7a24f304e47516156468bc5147275dc97156eaca3cf8d603f68639f8ece45b65c90357a412d42009d2b8412e90c789ae7f56517e35d0ca0390bf84b307 SHA512 c60d138e73cddd440ceba51e30247c341909cfd1440a3f3bc531de77600579c7d46154f8a1a724a3dae8529939dc32213b6b0359f5acac1ba801f29c53768cdd
+EBUILD ldap3-2.8.1.ebuild 618 BLAKE2B c46a4ec4eb2b66b6f8aa0de0abf7953da6ebabd602e4df0b79a289ef3e6efa9f6f9a147c6d74cde0dc0e690d5eb9bcf57deadb661b783cb1958e28b27a11723a SHA512 c5c760fd0f14598e56f18c834c1bebd1310249caf4a47ad0332b009ab8e022ea356dc4a1609b131827fd741b1c77f9e005e149a415291f3cd34f640b23fee996
MISC metadata.xml 667 BLAKE2B 3dd9eac5fd53006653b3e1416ea1b7b4445daee2d041dce6672043effb4a4dc919503ab06b18b6e077981749f25b787657a3f8ab7d68572eefcda78af4c15faa SHA512 f92f6b96a6d9c32f959d278edd654495b0e8350ade72dde717b285667c0a6a9f472ca164b8c5f7e96b6f4aab1f48368a4a5836f75ff5e55941f8953b6b02e747
diff --git a/dev-python/ldap3/ldap3-2.8.1.ebuild b/dev-python/ldap3/ldap3-2.8.1.ebuild
new file mode 100644
index 000000000000..27afe3e1be60
--- /dev/null
+++ b/dev-python/ldap3/ldap3-2.8.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A strictly RFC 4511 conforming LDAP V3 pure Python client"
+HOMEPAGE="https://github.com/cannatag/ldap3 https://pypi.python.org/pypi/ldap3"
+SRC_URI="https://github.com/cannatag/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/pyasn1-0.4.8[${PYTHON_USEDEP}]
+"
+# tests require a ldap server and extra configuration
+RESTRICT="test"
+
+distutils_enable_tests nose