summaryrefslogtreecommitdiff
path: root/dev-python/ldap3/ldap3-2.9.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /dev-python/ldap3/ldap3-2.9.1.ebuild
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'dev-python/ldap3/ldap3-2.9.1.ebuild')
-rw-r--r--dev-python/ldap3/ldap3-2.9.1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/ldap3/ldap3-2.9.1.ebuild b/dev-python/ldap3/ldap3-2.9.1.ebuild
new file mode 100644
index 000000000000..9258ccc46214
--- /dev/null
+++ b/dev-python/ldap3/ldap3-2.9.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="A strictly RFC 4511 conforming LDAP V3 pure Python client"
+HOMEPAGE="
+ https://github.com/cannatag/ldap3/
+ https://pypi.org/project/ldap3/"
+SRC_URI="https://github.com/cannatag/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+# tests require a ldap server and extra configuration
+RESTRICT="test"
+
+RDEPEND=">=dev-python/pyasn1-0.4.8[${PYTHON_USEDEP}]"