summaryrefslogtreecommitdiff
path: root/dev-python/lazy_loader
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-06 16:19:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-06 16:19:28 +0000
commit9afce155a599e5f4518f3c7913b6424ac13be12e (patch)
tree60420eafdcf940c0e4555d9aa8e4e9017a646344 /dev-python/lazy_loader
parenteb7aa327b218d640c8bda63ba0fd1ace2bd2d17b (diff)
gentoo auto-resync : 06:11:2023 - 16:19:27
Diffstat (limited to 'dev-python/lazy_loader')
-rw-r--r--dev-python/lazy_loader/Manifest3
-rw-r--r--dev-python/lazy_loader/lazy_loader-0.3.ebuild22
-rw-r--r--dev-python/lazy_loader/metadata.xml12
3 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/lazy_loader/Manifest b/dev-python/lazy_loader/Manifest
new file mode 100644
index 000000000000..a5b977514714
--- /dev/null
+++ b/dev-python/lazy_loader/Manifest
@@ -0,0 +1,3 @@
+DIST lazy_loader-0.3.tar.gz 12268 BLAKE2B b4b38202fa5c4558934dc6e2090b0585d9245a69824fb9548f5f24c3538232ce35fc1096978c4bb385bbc19b1008487cbe5b2e5a81f672acc790bfc1ac4b1bd7 SHA512 282efef8a20321bda07be382871fa3314ebf6c59f2451b33e613a72dd5b875fe7a7b8ea1336c879d79bf78cb808e1220a68ba30cd4e948d8c10ab0ca9ec23938
+EBUILD lazy_loader-0.3.ebuild 486 BLAKE2B 2778975f5d223b3d459ed7783e720e9a77d188d7cfc5760ff362acbdf0e9f7926bb85d7fbf8ac791c28c4df8aae4f53d3830fa1bd4d6d98dd48ab36b7de02cb0 SHA512 84717e5b810f2c9025ff5ce098dc262a703f737e1fb3e8bc50159e164399da7c09321c81aaaf8f14b92fe9b807a0815e4a319ae8995529c3790c457ccfc13bcb
+MISC metadata.xml 409 BLAKE2B 4dcc03dd53ed5a00f0210c5b54fab1942eea0f1a85127ff21cfa3ab26d3196fc7c046e4f152edba33b05843986160381c2ee5c3cd5a0cf60676ee2ad32cd3a6d SHA512 c5a33965de58c858dae11eaf6476f6b3c185e7351cebf64b5a50b3841d061ba43b65c0bccd1fb0432fe5c6e441456c00b0445313c137fcdd71de8939afeaa1e7
diff --git a/dev-python/lazy_loader/lazy_loader-0.3.ebuild b/dev-python/lazy_loader/lazy_loader-0.3.ebuild
new file mode 100644
index 000000000000..23803bb0880e
--- /dev/null
+++ b/dev-python/lazy_loader/lazy_loader-0.3.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Populate library namespace without incurring immediate import costs"
+HOMEPAGE="
+ https://github.com/scientific-python/lazy_loader
+ https://pypi.org/project/lazy_loader/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+distutils_enable_tests pytest
diff --git a/dev-python/lazy_loader/metadata.xml b/dev-python/lazy_loader/metadata.xml
new file mode 100644
index 000000000000..55037c181b9e
--- /dev/null
+++ b/dev-python/lazy_loader/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">lazy_loader</remote-id>
+ <remote-id type="github">scientific-python/lazy_loader</remote-id>
+ </upstream>
+</pkgmetadata>