summaryrefslogtreecommitdiff
path: root/dev-python/lazy-object-proxy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-15 20:53:45 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-15 20:53:45 +0000
commit20e7188871e6d724b707132f925b9872536a91a0 (patch)
tree1b8d527714db0a937011ad650939d9152d36506c /dev-python/lazy-object-proxy
parente4769acf6646f4b0ef28cb695cec8ed128aba920 (diff)
gentoo auto-resync : 15:12:2023 - 20:53:45
Diffstat (limited to 'dev-python/lazy-object-proxy')
-rw-r--r--dev-python/lazy-object-proxy/Manifest3
-rw-r--r--dev-python/lazy-object-proxy/files/lazy-object-proxy-1.10.0-pure-tests.patch29
-rw-r--r--dev-python/lazy-object-proxy/lazy-object-proxy-1.10.0.ebuild50
3 files changed, 82 insertions, 0 deletions
diff --git a/dev-python/lazy-object-proxy/Manifest b/dev-python/lazy-object-proxy/Manifest
index 21480c1df43b..36364ce13a63 100644
--- a/dev-python/lazy-object-proxy/Manifest
+++ b/dev-python/lazy-object-proxy/Manifest
@@ -1,3 +1,6 @@
+AUX lazy-object-proxy-1.10.0-pure-tests.patch 1020 BLAKE2B 4121388f3dd8535f1729fd239a5e01e006a5665d095504d6a9611a26914699787ef2c1379606fc0106acf1229911bad48d6f104e16afa89caa06f913d74b9d27 SHA512 68fc383fa494ae45a9addaed13404497423c9021bf0b85b19b72389c6a286510db3edcb38ff579be7144775a0a51da5ae21b7ca26be68a28b52222c9a0044401
+DIST lazy-object-proxy-1.10.0.tar.gz 43271 BLAKE2B f2146db4ebb3e48b4af36fa56a1656c3316896eab9e9b9c5450106b18df27a48a04c7ab8609384caf81899f956a20990e54818c836bd20b607766652d9797eca SHA512 0693a2b6d13909580e7b568a030b884f84fc1578b17e49ac4246572e3e8b18c05a2613572f24b908630528ecb606d149a106b46d079f2c42ced5172146e413c5
DIST lazy-object-proxy-1.9.0.tar.gz 42830 BLAKE2B 565315a3e855bc5335af717d1edc947fef57514c06036280d1f4666ab9642cf7e7b4bb145da87cbca14d9efa9f4869d7ad256031983a773580dc398fb7ce25e0 SHA512 2168254a71cf52ef406e5edf4653b9c8ae05392d4ad3c2e5e8e9f8db56152d968a77d14226acdf7d962f66d460c40add335615442f6f176d697c071f9cb137f5
+EBUILD lazy-object-proxy-1.10.0.ebuild 1162 BLAKE2B 7de214a9553e621366a2a2c2fa63dbe1c0f8b6154b3fc58f2cdf52ec1a3109b21862b6381e616d4ec518e4a8edefb50635b0d66fc51f0abcca2f8a17a9a65511 SHA512 e87cd97df0a5163eca4b5cd960986c9280e7a088bab9ffe80846c842e22d7c5f50a8a13c66eb3139002f739b3f6cb1d751f80d0e5a5a74896409421f4506fa4c
EBUILD lazy-object-proxy-1.9.0.ebuild 910 BLAKE2B 85533c25fd4d211813a03fc2e91d8a856e5acd351d0bbcf99babd44613770b548600c2dc1d476a1bf4170e4d4fc0d8f4133de13678c9d4ec88da320ffcb8c7cf SHA512 823f60c8dd0a742c9c504ff89bcec9c10e96a9b188f7c962a26f1803a0c20f90a13a541473a7b221c027a504c4bc9b7664e804dea308fbd88cb2e8d2fef17cde
MISC metadata.xml 540 BLAKE2B daf53065c3af28ec7316bab786a7ebfa6890de83bd6434d39052797a1d08d9e7e05fc437fd9994bc437ba0d38dc6ab1cb2e073c2c053fdf55817302800e97b19 SHA512 e66e27df4757f7d13912934551b7fb346d734789f1b0b17e5c875dd5261babf65188bd31966f502be19e953fd9bfd87a64d49ce8e1849b2122a30905d3639e9d
diff --git a/dev-python/lazy-object-proxy/files/lazy-object-proxy-1.10.0-pure-tests.patch b/dev-python/lazy-object-proxy/files/lazy-object-proxy-1.10.0-pure-tests.patch
new file mode 100644
index 000000000000..c7806c68bb7a
--- /dev/null
+++ b/dev-python/lazy-object-proxy/files/lazy-object-proxy-1.10.0-pure-tests.patch
@@ -0,0 +1,29 @@
+From 25decee2bd5a68d290dd3349aa9a72ce41b398b6 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Fri, 15 Dec 2023 17:45:42 +0100
+Subject: [PATCH] Support SETUPPY_FORCE_PURE in tests
+
+Support testing without the C extension if SETUPPY_FORCE_PURE is set.
+This makes the test suite behavior consistent with setup.py behavior.
+---
+ tests/conftest.py | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/tests/conftest.py b/tests/conftest.py
+index 11d0379..2ba3209 100644
+--- a/tests/conftest.py
++++ b/tests/conftest.py
+@@ -1,3 +1,4 @@
++import os
+ import sys
+
+ import pytest
+@@ -19,7 +20,7 @@ class FakeModule:
+ try:
+ from lazy_object_proxy.cext import Proxy
+ except ImportError:
+- if PYPY:
++ if PYPY or os.environ.get('SETUPPY_FORCE_PURE'):
+ pytest.skip(reason='C Extension not available.')
+ else:
+ raise
diff --git a/dev-python/lazy-object-proxy/lazy-object-proxy-1.10.0.ebuild b/dev-python/lazy-object-proxy/lazy-object-proxy-1.10.0.ebuild
new file mode 100644
index 000000000000..049fdedf879d
--- /dev/null
+++ b/dev-python/lazy-object-proxy/lazy-object-proxy-1.10.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A fast and thorough lazy object proxy"
+HOMEPAGE="
+ https://github.com/ionelmc/python-lazy-object-proxy/
+ https://pypi.org/project/lazy-object-proxy/
+ https://python-lazy-object-proxy.readthedocs.io/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="+native-extensions"
+
+BDEPEND="
+ >=dev-python/setuptools-scm-8[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ # https://github.com/ionelmc/python-lazy-object-proxy/pull/79
+ "${FILESDIR}/${P}-pure-tests.patch"
+)
+
+python_prepare_all() {
+ # No need to benchmark
+ sed \
+ -e '/benchmark/s:test_:_&:g' \
+ -e '/pytest.mark.benchmark/d' \
+ -i tests/test_lazy_object_proxy.py || die
+
+ distutils-r1_python_prepare_all
+
+ if use native-extensions; then
+ unset SETUPPY_FORCE_PURE
+ else
+ export SETUPPY_FORCE_PURE=1
+ fi
+}