summaryrefslogtreecommitdiff
path: root/dev-python/latexcodec/latexcodec-3.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-07 01:06:27 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-07 01:06:27 +0000
commit905e7d07da40378586e71ece65bd962b0b00c578 (patch)
tree1172da3268461b04a82fd99d5a6bbbaa16a7561e /dev-python/latexcodec/latexcodec-3.0.0.ebuild
parentf8f68d6f93dd8510c09261f47d4f64cadf303815 (diff)
gentoo auto-resync : 07:03:2024 - 01:06:26
Diffstat (limited to 'dev-python/latexcodec/latexcodec-3.0.0.ebuild')
-rw-r--r--dev-python/latexcodec/latexcodec-3.0.0.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/latexcodec/latexcodec-3.0.0.ebuild b/dev-python/latexcodec/latexcodec-3.0.0.ebuild
new file mode 100644
index 000000000000..3469fee5964e
--- /dev/null
+++ b/dev-python/latexcodec/latexcodec-3.0.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Lexer and codec to work with LaTeX code in Python"
+HOMEPAGE="
+ https://github.com/mcmtroffaes/latexcodec/
+ https://pypi.org/project/latexcodec/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+distutils_enable_tests pytest