summaryrefslogtreecommitdiff
path: root/dev-python/keystoneauth1
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-14 19:58:48 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-14 19:58:48 +0000
commit330454de22a51b01089472bf131acd28ea0c64ec (patch)
tree2d01a6b9daea431327a6b40431be1a29c6fdf90a /dev-python/keystoneauth1
parentf3b59a4d34d28f51cc97e3cd2eb23686d61c2002 (diff)
gentoo auto-resync : 14:02:2023 - 19:58:48
Diffstat (limited to 'dev-python/keystoneauth1')
-rw-r--r--dev-python/keystoneauth1/Manifest7
-rw-r--r--dev-python/keystoneauth1/keystoneauth1-5.1.0.ebuild65
-rw-r--r--dev-python/keystoneauth1/keystoneauth1-5.1.1.ebuild65
-rw-r--r--dev-python/keystoneauth1/keystoneauth1-5.1.2.ebuild62
-rw-r--r--dev-python/keystoneauth1/metadata.xml17
5 files changed, 216 insertions, 0 deletions
diff --git a/dev-python/keystoneauth1/Manifest b/dev-python/keystoneauth1/Manifest
new file mode 100644
index 000000000000..0036b5600e7b
--- /dev/null
+++ b/dev-python/keystoneauth1/Manifest
@@ -0,0 +1,7 @@
+DIST keystoneauth1-5.1.0.tar.gz 269600 BLAKE2B 5ea3885f34fe96f9a07f7bb5cbcadb1382ae5b06ae7afb627ad6b25b8b6d17ba5448f78cdcf1d89dd799d062950a8b66a1f58c5779fee7615db97557eb4ee9fa SHA512 1bb17818524256cf1a6a73d9bdd933451dae34f89be0fc6fb6a88f2207ce6b068e086b463abb904b0c9c20a9450b208321026c980e7af2cbbddc5bd75ee20d5b
+DIST keystoneauth1-5.1.1.tar.gz 269800 BLAKE2B 413149a14837ec4aebbb6e3a35ff3296ca0427a585262131373b57a53b6eddd1d61701a5eef705ab4db9e528c39a17e916b07615e7f41681cb4dd0f14583a851 SHA512 0c84e0e2bc251fdff54fb4fa7efa65e60865224c48da9a8b3f548101e828516d1cdb33d4a966015384a7107af7754017d6483c9d43a05788030a65766686ba48
+DIST keystoneauth1-5.1.2.tar.gz 269860 BLAKE2B 3c2d83c20991479b05675ce391357c26e4da2a2434f515a15aa900fe398f6fb5ae383cf6b4068a1205e49813406f632bdfe9490c435d5a8290b92c3dc0bdda8f SHA512 ff7e08114cc76d648c3879f44bb78b51e906fed2d34a9cf3e42199f1c5fc53394ad7b53f6cdfcb336436c482755d54891666369a0832ef9b846dd33dc4821791
+EBUILD keystoneauth1-5.1.0.ebuild 1970 BLAKE2B 1a60572345497904e33ea091b0e2e28f432f36722b4bd6f26d1e6def3159ede139189bf0e68e67beb5cf08254d3d62bbc8d317a566a758f893000f945e64224b SHA512 1ad032f5fa4202c329369d87231ff318dbbbc8514e01c1c569ae5c5fb4d3f7d6fc34cdfee6b1321cfa0488d320d73cfe95397dee82b230be43ddbbf9155299e6
+EBUILD keystoneauth1-5.1.1.ebuild 1973 BLAKE2B 1e6cf9a8667349bf4e0fdc69580d47347b769f9ab653c12564ce0cfb7ffa2a0bfe4f9a677c5d09145bdfb665422f6518d9834c853380f3f26cba9e5fdbc9d9eb SHA512 08b36aaae683849bbefe3be94a58e9386ecac48d2b304289b2964d9d3c13e8bcbf074b7f8ff2cf2e93149db649da0ed7c1580e94980c3a0b71cb8fd9a5810f54
+EBUILD keystoneauth1-5.1.2.ebuild 1868 BLAKE2B fb65122f772d7328510a49bb048ce413fbb92b25ce53e35356780b4fa07e8571527839ab8420ad83bf1bfa844c2d5ca6f1ed784f1becf0ad4a0c887557d3018c SHA512 205a9a207742286529ca1c491bd5a2ecd9f5806729ff3eee4cd83d685ac031a90e6dd42769c332372a70c3e968ca088bf1e51d64a9f375c4cc1b40336d3b0594
+MISC metadata.xml 518 BLAKE2B 8a84b6a7146096e67c0517623f0680cbe7772a48d8167b1aaf34dd12f7f626c84e60c0a15b3d90ae9df6483c33d7b51fc5cbf51d35e4f409e04573eb8fe18d1b SHA512 9a5b7fe8f29deed8ed59d6b3a96cfbacd5b566d6aa6eabd55545f02521d3dcc7ef7347632cdbead0735d28004ffe55a18550ee45cf8634253900f0190f140434
diff --git a/dev-python/keystoneauth1/keystoneauth1-5.1.0.ebuild b/dev-python/keystoneauth1/keystoneauth1-5.1.0.ebuild
new file mode 100644
index 000000000000..092b4dde4cb9
--- /dev/null
+++ b/dev-python/keystoneauth1/keystoneauth1-5.1.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+MY_P=keystoneauth1-${PV}
+DESCRIPTION="This package contains tools for authenticating to an OpenStack-based cloud"
+HOMEPAGE="https://github.com/openstack/keystoneauth"
+HOMEPAGE="
+ https://opendev.org/openstack/keystoneauth/
+ https://github.com/openstack/keystoneauth/
+ https://pypi.org/project/keystoneauth1/
+"
+SRC_URI="mirror://pypi/${MY_P::1}/keystoneauth1/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm arm64 ~riscv x86"
+
+RDEPEND="
+ >=dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/iso8601-0.1.11[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ >=dev-python/os-service-types-1.2.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/betamax-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/lxml-4.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oauthlib-0.6.2[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-5.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.12[${PYTHON_USEDEP}]
+ >=dev-python/requests-kerberos-0.8.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-mock-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/testresources-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ # relies on specific test runner name
+ sed -i -e 's:run\.py:unittest_or_fail.py:' \
+ keystoneauth1/tests/unit/test_session.py || die
+ # remove the test that requires hacking
+ rm keystoneauth1/tests/unit/test_hacking_checks.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ eunittest -b
+}
diff --git a/dev-python/keystoneauth1/keystoneauth1-5.1.1.ebuild b/dev-python/keystoneauth1/keystoneauth1-5.1.1.ebuild
new file mode 100644
index 000000000000..d454d61a3df0
--- /dev/null
+++ b/dev-python/keystoneauth1/keystoneauth1-5.1.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+MY_P=keystoneauth1-${PV}
+DESCRIPTION="This package contains tools for authenticating to an OpenStack-based cloud"
+HOMEPAGE="https://github.com/openstack/keystoneauth"
+HOMEPAGE="
+ https://opendev.org/openstack/keystoneauth/
+ https://github.com/openstack/keystoneauth/
+ https://pypi.org/project/keystoneauth1/
+"
+SRC_URI="mirror://pypi/${MY_P::1}/keystoneauth1/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/iso8601-0.1.11[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ >=dev-python/os-service-types-1.2.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/betamax-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/lxml-4.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oauthlib-0.6.2[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-5.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.12[${PYTHON_USEDEP}]
+ >=dev-python/requests-kerberos-0.8.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-mock-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/testresources-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ # relies on specific test runner name
+ sed -i -e 's:run\.py:unittest_or_fail.py:' \
+ keystoneauth1/tests/unit/test_session.py || die
+ # remove the test that requires hacking
+ rm keystoneauth1/tests/unit/test_hacking_checks.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ eunittest -b
+}
diff --git a/dev-python/keystoneauth1/keystoneauth1-5.1.2.ebuild b/dev-python/keystoneauth1/keystoneauth1-5.1.2.ebuild
new file mode 100644
index 000000000000..241422ce6c5d
--- /dev/null
+++ b/dev-python/keystoneauth1/keystoneauth1-5.1.2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="This package contains tools for authenticating to an OpenStack-based cloud"
+HOMEPAGE="https://github.com/openstack/keystoneauth"
+HOMEPAGE="
+ https://opendev.org/openstack/keystoneauth/
+ https://github.com/openstack/keystoneauth/
+ https://pypi.org/project/keystoneauth1/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/iso8601-0.1.11[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ >=dev-python/os-service-types-1.2.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/betamax-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/lxml-4.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oauthlib-0.6.2[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-5.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.12[${PYTHON_USEDEP}]
+ >=dev-python/requests-kerberos-0.8.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-mock-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/testresources-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ # relies on specific test runner name
+ sed -i -e 's:run\.py:unittest_or_fail.py:' \
+ keystoneauth1/tests/unit/test_session.py || die
+ # remove the test that requires hacking
+ rm keystoneauth1/tests/unit/test_hacking_checks.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ eunittest -b
+}
diff --git a/dev-python/keystoneauth1/metadata.xml b/dev-python/keystoneauth1/metadata.xml
new file mode 100644
index 000000000000..e27877a6d52a
--- /dev/null
+++ b/dev-python/keystoneauth1/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">openstack/keystoneauth</remote-id>
+ <remote-id type="pypi">keystoneauth1</remote-id>
+ </upstream>
+</pkgmetadata>