summaryrefslogtreecommitdiff
path: root/dev-python/kconfiglib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-07-19 22:05:27 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-07-19 22:05:27 +0100
commit121ed4eec41fbf03e1998d09eede1bf449da63b9 (patch)
treece9341d77d1507f67d4a3a1472da9011b5baa0a8 /dev-python/kconfiglib
parentdd762ff83c330186ee2ede002e08b2f780cddd51 (diff)
gentoo resync : 19.07.2019
Diffstat (limited to 'dev-python/kconfiglib')
-rw-r--r--dev-python/kconfiglib/Manifest3
-rw-r--r--dev-python/kconfiglib/files/kconfiglib-12.12.1-setup.patch16
-rw-r--r--dev-python/kconfiglib/kconfiglib-12.12.1.ebuild5
3 files changed, 21 insertions, 3 deletions
diff --git a/dev-python/kconfiglib/Manifest b/dev-python/kconfiglib/Manifest
index 17b91ac31a59..f57046fc3b8a 100644
--- a/dev-python/kconfiglib/Manifest
+++ b/dev-python/kconfiglib/Manifest
@@ -1,3 +1,4 @@
+AUX kconfiglib-12.12.1-setup.patch 463 BLAKE2B f2e781ea3f2e28b308424b1688b9ccb575450bede07c4f00fb24a8196c3f8c514e3d4af222d86203f369e5dd9f2b97f778cddac757d1591d1c4af34a59e7e631 SHA512 c3d0c56bf3a84af57f0ef0fbdd987b3cfa8acdf1828efbb4e66d928256d47a64ad116cd7d9c66d19b5a8b1dc167603e0f8db1aeec2ddbcc0cec98235771e50f1
DIST kconfiglib-12.12.1.tar.gz 181307 BLAKE2B d256148bd6bf01f7951c78751604eae1be4c2fc156b815bdb570e6fcf185c2f5c97259f6ce0ed275104234ff7180afa2000a81feb281e745a8a0c4db162f57b9 SHA512 49e8746e6c83a93b7500130b21b864346ab8106c0c161de0ec62b3efff794080e734d34d88cd9c816c0d6514465729fbc3a4334fcc9c0a68f17c1688bb210325
-EBUILD kconfiglib-12.12.1.ebuild 1047 BLAKE2B 0c4bef5cbed70c1c39a602438a7fddf86f36059837d5595eba561c6f2b3706593c7fcbaf41595b070a75b3473019a5a95eb745c658c54f6458ebdef276c8c6d2 SHA512 c6f8f55aecdd22e37b85de9808a6b53bdb50cd4fa081e3ce7f65fcfcf5d561f1ed308087fa5fb721721fd9554d020c07cfd10791bec4ffc8346db4583ec5cedf
+EBUILD kconfiglib-12.12.1.ebuild 1049 BLAKE2B 34797f558424ea5b8a91ded661b7f180042c78d65dbae66ed37686ca4438066b9e53ff2795af642d96ca1e819d41f10668e47ee7b08e7a657b1227829d87c452 SHA512 ec2a600938d4a8296952aba0d88dbc03ce499824db71ab775ed923b4aa62af04de7928ce8919f262924d3ed10189254a3f860c1e8635e38456f1e7a199d34243
MISC metadata.xml 331 BLAKE2B cf19e7c3a4a2511e58382941904de06eb12e21c0a1f27c89fd3f61ff1e2f96d9e8509aba80f52080ce4a53da8f99e8a15685803b143fbc9071d33ae6e815a1e1 SHA512 453f9a6063705a3f9db24e5c0658e31c73d234dead14ccecd8d46fe56f26b16729f4f46c0ff7471689c60eef5d9c006b455a14f349f1249ae2e9f0b677ef80f8
diff --git a/dev-python/kconfiglib/files/kconfiglib-12.12.1-setup.patch b/dev-python/kconfiglib/files/kconfiglib-12.12.1-setup.patch
new file mode 100644
index 000000000000..b5225e90d5d9
--- /dev/null
+++ b/dev-python/kconfiglib/files/kconfiglib-12.12.1-setup.patch
@@ -0,0 +1,16 @@
+Python2's ConfigParser module used by setuptools throws parsing errors when
+encountering tab characters.
+
+--- Kconfiglib-12.12.1/setup.cfg
++++ Kconfiglib-12.12.1/setup.cfg
+@@ -1,6 +1,6 @@
+ [bdist_wheel]
+- # We support both Python 2 and Python 3
+- universal = 1
++# We support both Python 2 and Python 3
++universal = 1
+ [metadata]
+- # Include the license file in wheels
+- license_file = LICENSE.txt
++# Include the license file in wheels
++license_file = LICENSE.txt
diff --git a/dev-python/kconfiglib/kconfiglib-12.12.1.ebuild b/dev-python/kconfiglib/kconfiglib-12.12.1.ebuild
index 42e22c8f41fb..b1a5baccde7c 100644
--- a/dev-python/kconfiglib/kconfiglib-12.12.1.ebuild
+++ b/dev-python/kconfiglib/kconfiglib-12.12.1.ebuild
@@ -2,8 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-# menuconfig script doesn't work on py2 so skip it
-PYTHON_COMPAT=( python3_{5,6,7} pypy3 )
+PYTHON_COMPAT=( python{2_7,3_{5,6,7}} pypy{,3} )
PYTHON_REQ_USE="ncurses"
inherit distutils-r1
@@ -24,6 +23,8 @@ RDEPEND="${DEPEND}"
S=${WORKDIR}/${P/k/K}
+PATCHES=( "${FILESDIR}"/${P}-setup.patch )
+
python_prepare_all() {
distutils-r1_python_prepare_all