summaryrefslogtreecommitdiff
path: root/dev-python/kazoo/kazoo-2.8.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-24 13:10:40 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-24 13:10:40 +0000
commitc92d0cd2b34d17bce6d5bb4e3a4fc00af4193c99 (patch)
tree517559f918260cf91e7bdd4e484aa6fe9085cb9f /dev-python/kazoo/kazoo-2.8.0.ebuild
parenta59ffccce3bf214fae9932cc42400eeeaec25c6c (diff)
gentoo auto-resync : 24:11:2022 - 13:10:39
Diffstat (limited to 'dev-python/kazoo/kazoo-2.8.0.ebuild')
-rw-r--r--dev-python/kazoo/kazoo-2.8.0.ebuild52
1 files changed, 0 insertions, 52 deletions
diff --git a/dev-python/kazoo/kazoo-2.8.0.ebuild b/dev-python/kazoo/kazoo-2.8.0.ebuild
deleted file mode 100644
index d39da87a6cfa..000000000000
--- a/dev-python/kazoo/kazoo-2.8.0.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="A high-level Python library that makes it easier to use Apache Zookeeper"
-HOMEPAGE="https://kazoo.readthedocs.org/ https://github.com/python-zk/kazoo/ https://pypi.org/project/kazoo/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-IUSE="doc"
-
-RDEPEND="
- dev-python/six[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/graphviz[${PYTHON_USEDEP}]
- >=dev-python/objgraph-3.4.0[${PYTHON_USEDEP}]
- sys-cluster/zookeeper-bin
- )
-"
-
-distutils_enable_sphinx docs
-distutils_enable_tests pytest
-
-src_prepare() {
- # TODO
- sed -e 's:test_close:_&:' \
- -e 's:test_delete_operation:_&:' \
- -i kazoo/tests/test_cache.py || die
- distutils-r1_src_prepare
-}
-
-src_test() {
- local pkgver=$(best_version sys-cluster/zookeeper-bin)
- pkgver=${pkgver#sys-cluster/zookeeper-bin-}
- export ZOOKEEPER_VERSION=${pkgver%-r*}
- export ZOOKEEPER_PATH=${BROOT}/opt/zookeeper-bin
- distutils-r1_src_test
-}
-
-python_install_all() {
- local DOCS=( {CHANGES,CONTRIBUTING,README}.md )
- distutils-r1_python_install_all
-}