summaryrefslogtreecommitdiff
path: root/dev-python/jwcrypto
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-08 09:59:13 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-08 09:59:13 +0000
commit31a02d889028bf30f7b376b935aa05c2140d3c66 (patch)
tree6b211d58d5072baba31037fda71f6f421c38e5c8 /dev-python/jwcrypto
parent8f53b8011f9c960a02775a71c3805e13e72237fd (diff)
gentoo auto-resync : 08:02:2024 - 09:59:13
Diffstat (limited to 'dev-python/jwcrypto')
-rw-r--r--dev-python/jwcrypto/Manifest2
-rw-r--r--dev-python/jwcrypto/jwcrypto-1.5.3.ebuild37
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/jwcrypto/Manifest b/dev-python/jwcrypto/Manifest
index df769b027fde..2bd29ccae278 100644
--- a/dev-python/jwcrypto/Manifest
+++ b/dev-python/jwcrypto/Manifest
@@ -1,3 +1,5 @@
DIST jwcrypto-1.5.1.gh.tar.gz 96563 BLAKE2B 13b39b27825031d4f30e1399bac085ba846551b5e50c49ae2a1ff31182e47a896ef9bfdd1705a40e59ddeb6850ba7bafd19ccf83d9f8177c47936e220df881db SHA512 fecb993a1157b6e689d3e845c8839f3178e32ab7fc920bf6b7328705293dae5e3d1424532b066f6dedd9c25a5cdeec91089ed4b83c4592cf6e1690419b5a5539
+DIST jwcrypto-1.5.3.gh.tar.gz 96597 BLAKE2B 6efffce256f7652ca79316c0a4148df61bec65d74f275ffad6f665cfb26c14137ecc7ec219fa30c0f8dcdc3de8468a94dc158ed0b1f973b8d5a451fa1081fcae SHA512 90081959ebd3ff0d003e8bfb6f25e51243c6f7d522d085f5fa63e2a810707b070069a387fbf067c16e8bf3d8e84f9387c399a49a23e20c4d2007ab53e99f041d
EBUILD jwcrypto-1.5.1.ebuild 845 BLAKE2B b0c7c3320880be5ac70e9e95c3968434070e7b5b272a32c86bad42e8831e98e50b0b42cc047355718ce27c11a0373f53d186056675d4becf21556cceb52fbaa2 SHA512 db0683040c46a27b56f3ba9fe78747edc61a7cfec22bff4b8e2fffed1bc863c09898d9063ec26654d4b9cf5247771d4c0925427167753b32d0dfb3d8735e01b4
+EBUILD jwcrypto-1.5.3.ebuild 855 BLAKE2B 00f5a63516d7a526988d3ec76930767efd391e13ae73f1060b798296fae35ec8507b2119aad6041204457c47e72dad9d56d82800004220655d58244b1772c199 SHA512 d0543094363f40ea1335ee45aab6fc1a0cc072b162a7d21fa6245d22a401a0a4679a1d1f4b6555be7d3ec87321b7323b1c45d1cc832f758f7c49b4ff45920b6b
MISC metadata.xml 369 BLAKE2B c7868e0b20a2875964290642cddb457b71628e361f0e032875ac45f4405abeb76c8c53bcfe623c9a2e49ea6e184505503b4e43f34c456528ff3250aea5110b10 SHA512 a1fec6ac31bbb096e508b0ebd644aa8a96418e6972d852512d4b7702b67f241f858610235dbd68430c588d8b837c7a0866f333c8aab182e7cd01e10325031d34
diff --git a/dev-python/jwcrypto/jwcrypto-1.5.3.ebuild b/dev-python/jwcrypto/jwcrypto-1.5.3.ebuild
new file mode 100644
index 000000000000..4ecae46ff05f
--- /dev/null
+++ b/dev-python/jwcrypto/jwcrypto-1.5.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Implements JWK,JWS,JWE specifications using python-cryptography"
+HOMEPAGE="
+ https://github.com/latchset/jwcrypto/
+ https://pypi.org/project/jwcrypto/
+"
+SRC_URI="
+ https://github.com/latchset/jwcrypto/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/cryptography-3.4[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs/source
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Do not install doc in non-standard paths
+ sed -e "/data_files/d" -i setup.py || die
+ distutils-r1_python_prepare_all
+}