summaryrefslogtreecommitdiff
path: root/dev-python/jupyterlab
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /dev-python/jupyterlab
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'dev-python/jupyterlab')
-rw-r--r--dev-python/jupyterlab/Manifest2
-rw-r--r--dev-python/jupyterlab/jupyterlab-3.2.5-r1.ebuild41
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/jupyterlab/Manifest b/dev-python/jupyterlab/Manifest
index 929b8e2d2856..2770365d01b7 100644
--- a/dev-python/jupyterlab/Manifest
+++ b/dev-python/jupyterlab/Manifest
@@ -1,3 +1,5 @@
DIST jupyterlab-3.2.1.tar.gz 17073190 BLAKE2B 8cde66b024fe46270494735de8ab2ae0747a926c9ee1daf2d49514ce813bbc3570e676afde0fdae2328e65820fb8511195d097a17b7e07f800f93c4d98968709 SHA512 b84cdd5c70861300d84d3d6d8f3ba5e01482dd29105949c4b14b3d6512749bc4c8bb091f1d9246de181e2714ddf840a17903eb43750bd13ae9ca96c5119d5661
+DIST jupyterlab-3.2.5.tar.gz 17056795 BLAKE2B 1c4c8de7b20d4b6ea42d0aaa8986fd08d31e8d31289c9c72a691746275146e4a2b8fbfc1f7bcbaf374d063cbda7a39e941677265b211ebe3f2d6c37fad740624 SHA512 396717554a70cf0ed0d2a6b3d2929ff51659453d4570e014277c82a48c5974fdac345e391882a3e0114f9bda13a8436072a032db4c8b8d1b338396248c176fa3
EBUILD jupyterlab-3.2.1.ebuild 1066 BLAKE2B f5b806db17417e9b9ab8ccbf027c48773de84f26c08946e329c460f0cba4a13da151d16f2172cc1b9cf7e696805146ecfe2a9d4fd82d461934158039a9e5438f SHA512 00db002f7e34af013e4822dfdd2853df7a2a29e5c77647e6349ef2edd0f314ed71d6ffea27f4f4e016ebba6a8ab30f0951c3c135b6924bb810a65337ca3f9bbb
+EBUILD jupyterlab-3.2.5-r1.ebuild 1065 BLAKE2B 158071b39dc99ca79c0e615b6023c903334f5561698a0da85579ed76011e5e87af985a9f5381c9166fe90ddbfcc4d3744ce336e8a5e5d3f988fb3fd90ccd9289 SHA512 63e2180183415a081a1157b75ac35b7287f0c09cd0912e1ec0ebce3797e97adea4ef949fff2cd9555ed56cadcc351ac7c36b52897d79f2297e790705c9430463
MISC metadata.xml 412 BLAKE2B f0b40e19f8ba9dc116f0e4a882cabab6376f22d1eaeb3eac58ecff465ee2aff3564ddbf55e4ffb8971807a39945109a164037a954419671a274d3ac558b102ea SHA512 b6149a03585ca04bc3bf6f3ea6055e8e1fcb620a771359d150df7c22ee16bf09f57c8037df2161021fac0c194be0ac5ec79a31f0511d785e0c5b1ca96d817e42
diff --git a/dev-python/jupyterlab/jupyterlab-3.2.5-r1.ebuild b/dev-python/jupyterlab/jupyterlab-3.2.5-r1.ebuild
new file mode 100644
index 000000000000..2618ff746036
--- /dev/null
+++ b/dev-python/jupyterlab/jupyterlab-3.2.5-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="JupyterLab computational environment"
+HOMEPAGE="https://jupyter.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD MIT GPL-3 Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# TODO: package openapi et al
+RESTRICT="test"
+
+BDEPEND="dev-python/jupyter_packaging[${PYTHON_USEDEP}]"
+
+RDEPEND="
+ dev-python/ipython[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/jupyter_core[${PYTHON_USEDEP}]
+ dev-python/jupyterlab_server[${PYTHON_USEDEP}]
+ dev-python/jupyter_server[${PYTHON_USEDEP}]
+ dev-python/nbclassic[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.1[${PYTHON_USEDEP}]
+ >=www-servers/tornado-6.1[${PYTHON_USEDEP}]
+ net-libs/nodejs
+"
+
+distutils_enable_tests pytest
+# TODO: package myst_parser
+#distutils_enable_sphinx docs/source dev-python/sphinx_rtd_theme
+
+python_install_all() {
+ distutils-r1_python_install_all
+ mv "${ED}/usr/etc" "${ED}/etc" || die
+}