summaryrefslogtreecommitdiff
path: root/dev-python/jupyterlab
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-09 09:47:51 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-09 09:47:51 +0100
commit65a4d80ebaba5d4d407b3d09320b337e0ca20f0a (patch)
tree8a0a31fde569e875a6a429ce5473050781aa7803 /dev-python/jupyterlab
parent29d63ef1ebd8704a96d50408d409b9ef0ff3787b (diff)
gentoo auto-resync : 09:06:2023 - 09:47:51
Diffstat (limited to 'dev-python/jupyterlab')
-rw-r--r--dev-python/jupyterlab/Manifest2
-rw-r--r--dev-python/jupyterlab/jupyterlab-4.0.2.ebuild77
2 files changed, 79 insertions, 0 deletions
diff --git a/dev-python/jupyterlab/Manifest b/dev-python/jupyterlab/Manifest
index cdb468f5aebb..1f5869304c7a 100644
--- a/dev-python/jupyterlab/Manifest
+++ b/dev-python/jupyterlab/Manifest
@@ -1,5 +1,7 @@
DIST jupyterlab-3.6.3.tar.gz 16847186 BLAKE2B 6916722469ab100a1a240b8a565c9800f35535b2a9b2c39a6bfd275b078d88df9faa1f12d4ce3819155af7b0ed22282836f9b233534bd3e63d8a330d1cd7cd21 SHA512 3d6b4781f9fab02504b2c0223a4d060d80c3442fa6ac53ae326296d69942d68f8545450f671f6ba65c7c4e218aad62ef4f4ceb658899c21aaff3640c3055d364
DIST jupyterlab-4.0.0.tar.gz 18227222 BLAKE2B 98a6e1cfb4dd72a2cd183cb7210e45a70a9dc9f77200c42f58340889ac97dc2f7bcdb18822f7b9618e955dcf651bfc4b3d2087677cc112a4e2085fe6d70c3014 SHA512 7ed40068fe3f617870bc3fbad0401145baaf79e1688bd2e5a879ad92c8c1058a1a0c5fffafe7c1c0fbf1e77c2bef8e975f39d14e54b739bf8de653c264bffaa6
+DIST jupyterlab-4.0.2.tar.gz 18225766 BLAKE2B 2967cdc189ef2af543344513520cf13f47510e5edfd92129acd4114eb4d2ef33b5f6dcf64f18fe0a45313d61354a8ae8edd498d05cdd35c66d41d4b915ed31e3 SHA512 81cc0bddd2067fe4ac127d0da1b42fafc54a973f15622e31be74fdd5bea0d6745b00fdfef83118d5d500971779db74844e8c28c3dafd24a9a083af0e98749c0e
EBUILD jupyterlab-3.6.3.ebuild 2744 BLAKE2B 9cfdab0afb8feff32c1eb0d4f1e641860ff59e72080448805cfc11cfe3a565a7c8fc18b4013f5b78ff83304b21df03ad939d81eac8d9afbbf2bd59ab75f778b2 SHA512 a5ff778dee692241083a51d970ce5025db0976b6abc4c14e15fe39b48427a5a27aee5f91bc6989b3a109ae11590d89e66f15b3dd573cc79caf90118d022ec71c
EBUILD jupyterlab-4.0.0.ebuild 2566 BLAKE2B fae16c460f77211214d52ec0d1aa6fc681f8aaf2fb75c5bcea1daeb8688047a0cafdc4831f441a1b3337e1d2e821ed96383378e6e39d29125a16b18582f9ebe5 SHA512 f32cc330a126317a963b4b1391881f9ba1d7ae4154291b931fc4cfd22ff9dc5acdf2063c28e80018b88fe534df53b8ed2f674cf6fcb258c351ef2fb0b4cd9d42
+EBUILD jupyterlab-4.0.2.ebuild 2567 BLAKE2B 8caa39c3efcd6f703f2be150c6282d3bb6398c32b61e751d4737683dc874d2ad52196c72139dd37694712e2d7f537a5192f4d6f55a16cbe9d15815967f3b51b9 SHA512 800f9485b38e1b27830e8ad990b9cb93a15d0c7e9a2487bc99c350cdd2b0f277d3f7e6448abcbfaf403b16c9589da08f4d87768fe698da2328bacdc5c9c6c1a5
MISC metadata.xml 412 BLAKE2B f0b40e19f8ba9dc116f0e4a882cabab6376f22d1eaeb3eac58ecff465ee2aff3564ddbf55e4ffb8971807a39945109a164037a954419671a274d3ac558b102ea SHA512 b6149a03585ca04bc3bf6f3ea6055e8e1fcb620a771359d150df7c22ee16bf09f57c8037df2161021fac0c194be0ac5ec79a31f0511d785e0c5b1ca96d817e42
diff --git a/dev-python/jupyterlab/jupyterlab-4.0.2.ebuild b/dev-python/jupyterlab/jupyterlab-4.0.2.ebuild
new file mode 100644
index 000000000000..b514173b1f5d
--- /dev/null
+++ b/dev-python/jupyterlab/jupyterlab-4.0.2.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=hatchling
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="JupyterLab computational environment"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyterlab/jupyterlab/
+ https://pypi.org/project/jupyterlab/
+"
+
+LICENSE="BSD MIT GPL-3 Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/async-lru[${PYTHON_USEDEP}]
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ >=dev-python/jinja-3.0.3[${PYTHON_USEDEP}]
+ dev-python/jupyter-core[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-lsp-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-server-2.4.0[${PYTHON_USEDEP}]
+ <dev-python/jupyter-server-3[${PYTHON_USEDEP}]
+ >=dev-python/jupyterlab-server-2.19[${PYTHON_USEDEP}]
+ <dev-python/jupyterlab-server-3[${PYTHON_USEDEP}]
+ >=dev-python/notebook-shim-0.2[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/tomli[${PYTHON_USEDEP}]
+ >=dev-python/tornado-6.2[${PYTHON_USEDEP}]
+ dev-python/traitlets[${PYTHON_USEDEP}]
+ net-libs/nodejs
+"
+
+BDEPEND="
+ dev-python/hatch-jupyter-builder[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-console-scripts[${PYTHON_USEDEP}]
+ >=dev-python/pytest-jupyter-0.5.3[${PYTHON_USEDEP}]
+ dev-python/pytest-tornasync[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/requests-cache[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_DESELECT=(
+ # These tests call npm and want internet
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_uninstall_core_extension
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_install_and_uninstall_pinned_folder
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_install_and_uninstall_pinned
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_build_custom_minimal_core_config
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_build_custom
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_build_check
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_build
+ jupyterlab/tests/test_build_api.py::TestBuildAPI::test_clear
+ jupyterlab/tests/test_build_api.py::TestBuildAPI::test_build
+)
+
+EPYTEST_IGNORE=(
+ jupyterlab/tests/test_announcements.py
+)
+
+distutils_enable_tests pytest
+# TODO: package sphinx_copybutton
+#distutils_enable_sphinx docs/source dev-python/sphinx-rtd-theme dev-python/myst-parser
+
+python_install_all() {
+ distutils-r1_python_install_all
+ mv "${ED}/usr/etc" "${ED}/etc" || die
+}