summaryrefslogtreecommitdiff
path: root/dev-python/jupyterlab
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-04 09:17:06 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-04 09:17:06 +0100
commit5e0e6a28799c4a5134e55d203b373f1d6811c004 (patch)
tree6512a6801267b6752a4b464d52debaecb9caeedd /dev-python/jupyterlab
parentf71e91f3fbcdebf01a5ecf58164716586daeaa5b (diff)
gentoo auto-resync : 04:08:2023 - 09:17:05
Diffstat (limited to 'dev-python/jupyterlab')
-rw-r--r--dev-python/jupyterlab/Manifest2
-rw-r--r--dev-python/jupyterlab/jupyterlab-4.0.4.ebuild77
2 files changed, 79 insertions, 0 deletions
diff --git a/dev-python/jupyterlab/Manifest b/dev-python/jupyterlab/Manifest
index 26fe0abfbb61..659d52ca5492 100644
--- a/dev-python/jupyterlab/Manifest
+++ b/dev-python/jupyterlab/Manifest
@@ -1,5 +1,7 @@
DIST jupyterlab-3.6.3.tar.gz 16847186 BLAKE2B 6916722469ab100a1a240b8a565c9800f35535b2a9b2c39a6bfd275b078d88df9faa1f12d4ce3819155af7b0ed22282836f9b233534bd3e63d8a330d1cd7cd21 SHA512 3d6b4781f9fab02504b2c0223a4d060d80c3442fa6ac53ae326296d69942d68f8545450f671f6ba65c7c4e218aad62ef4f4ceb658899c21aaff3640c3055d364
DIST jupyterlab-4.0.3.tar.gz 18222352 BLAKE2B 7dee4109e94173d35794c2b3a05de5cbab145fc031b22628ca4b5c1d97497658807b0a9b713d58a7aae3a38a64a37e04e535988d727cab6ba3c3aebe2ff6c0a2 SHA512 cb7694c1398cbf1b061d385518d08d5ff4411bc7f53828d99edd3cf8420d39c09d99e1ee061d60a86d83e640c37777bfd4f98ce71276366f291f784f23740d4d
+DIST jupyterlab-4.0.4.tar.gz 18223782 BLAKE2B 8f2b157d27c68fba62fcfdeeb055b0c9b646987d2f31447b87720110ec2331ddad90c0288ad7554faa26674bf810d92d99f1924e2d34f81d2303a4ab6b213cd9 SHA512 23479cee2405ddc42a11c477cb93fad6cb5481a70766d48c1f7f1e498481c36a0dca47c5523ff3fc97aacfd86a37debd53cc3570e3e0916cc0a6cb526d99a574
EBUILD jupyterlab-3.6.3.ebuild 2744 BLAKE2B 9cfdab0afb8feff32c1eb0d4f1e641860ff59e72080448805cfc11cfe3a565a7c8fc18b4013f5b78ff83304b21df03ad939d81eac8d9afbbf2bd59ab75f778b2 SHA512 a5ff778dee692241083a51d970ce5025db0976b6abc4c14e15fe39b48427a5a27aee5f91bc6989b3a109ae11590d89e66f15b3dd573cc79caf90118d022ec71c
EBUILD jupyterlab-4.0.3.ebuild 2571 BLAKE2B 4afda064ba9209bb9aad9fb11467d46a5b0740c8f2dbb05edd6d74274fb2ce65651a35713f24115a58bb24327705f486f61d85a2168a61d8414699d479582ce2 SHA512 2cb0315f4f5069465d3b7bec38121b85de8c8eaa7cb3aac47e028aae6b885262d4fd72f00869a5fd1db07381036dd929609b8b98661d007184e16cd69fc025fd
+EBUILD jupyterlab-4.0.4.ebuild 2571 BLAKE2B 4afda064ba9209bb9aad9fb11467d46a5b0740c8f2dbb05edd6d74274fb2ce65651a35713f24115a58bb24327705f486f61d85a2168a61d8414699d479582ce2 SHA512 2cb0315f4f5069465d3b7bec38121b85de8c8eaa7cb3aac47e028aae6b885262d4fd72f00869a5fd1db07381036dd929609b8b98661d007184e16cd69fc025fd
MISC metadata.xml 412 BLAKE2B f0b40e19f8ba9dc116f0e4a882cabab6376f22d1eaeb3eac58ecff465ee2aff3564ddbf55e4ffb8971807a39945109a164037a954419671a274d3ac558b102ea SHA512 b6149a03585ca04bc3bf6f3ea6055e8e1fcb620a771359d150df7c22ee16bf09f57c8037df2161021fac0c194be0ac5ec79a31f0511d785e0c5b1ca96d817e42
diff --git a/dev-python/jupyterlab/jupyterlab-4.0.4.ebuild b/dev-python/jupyterlab/jupyterlab-4.0.4.ebuild
new file mode 100644
index 000000000000..01ca307b6a24
--- /dev/null
+++ b/dev-python/jupyterlab/jupyterlab-4.0.4.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=hatchling
+
+inherit distutils-r1 pypi xdg
+
+DESCRIPTION="JupyterLab computational environment"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyterlab/jupyterlab/
+ https://pypi.org/project/jupyterlab/
+"
+
+LICENSE="BSD MIT GPL-3 Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/async-lru[${PYTHON_USEDEP}]
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ >=dev-python/jinja-3.0.3[${PYTHON_USEDEP}]
+ dev-python/jupyter-core[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-lsp-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-server-2.4.0[${PYTHON_USEDEP}]
+ <dev-python/jupyter-server-3[${PYTHON_USEDEP}]
+ >=dev-python/jupyterlab-server-2.19[${PYTHON_USEDEP}]
+ <dev-python/jupyterlab-server-3[${PYTHON_USEDEP}]
+ >=dev-python/notebook-shim-0.2[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/tomli[${PYTHON_USEDEP}]
+ >=dev-python/tornado-6.2[${PYTHON_USEDEP}]
+ dev-python/traitlets[${PYTHON_USEDEP}]
+ net-libs/nodejs
+"
+
+BDEPEND="
+ dev-python/hatch-jupyter-builder[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-console-scripts[${PYTHON_USEDEP}]
+ >=dev-python/pytest-jupyter-0.5.3[${PYTHON_USEDEP}]
+ dev-python/pytest-tornasync[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/requests-cache[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_DESELECT=(
+ # These tests call npm and want internet
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_uninstall_core_extension
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_install_and_uninstall_pinned_folder
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_install_and_uninstall_pinned
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_build_custom_minimal_core_config
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_build_custom
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_build_check
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_build
+ jupyterlab/tests/test_build_api.py::TestBuildAPI::test_clear
+ jupyterlab/tests/test_build_api.py::TestBuildAPI::test_build
+)
+
+EPYTEST_IGNORE=(
+ jupyterlab/tests/test_announcements.py
+)
+
+distutils_enable_tests pytest
+# TODO: package sphinx_copybutton
+#distutils_enable_sphinx docs/source dev-python/sphinx-rtd-theme dev-python/myst-parser
+
+python_install_all() {
+ distutils-r1_python_install_all
+ mv "${ED}/usr/etc" "${ED}/etc" || die
+}