summaryrefslogtreecommitdiff
path: root/dev-python/jupyterlab
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-24 12:57:16 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-24 12:57:16 +0000
commit1f23f671d001ca7a0073e504f5ae0184eb5d024d (patch)
tree6747e05170df64a1585f36519a780db2d90f2a11 /dev-python/jupyterlab
parent98bd6c82c526d2c4239d3d194fa1a1a818784552 (diff)
gentoo auto-resync : 24:01:2023 - 12:57:16
Diffstat (limited to 'dev-python/jupyterlab')
-rw-r--r--dev-python/jupyterlab/Manifest2
-rw-r--r--dev-python/jupyterlab/jupyterlab-3.5.3.ebuild76
2 files changed, 78 insertions, 0 deletions
diff --git a/dev-python/jupyterlab/Manifest b/dev-python/jupyterlab/Manifest
index 57b64835f3df..fbe53a170ad8 100644
--- a/dev-python/jupyterlab/Manifest
+++ b/dev-python/jupyterlab/Manifest
@@ -1,5 +1,7 @@
DIST jupyterlab-3.5.0.tar.gz 17110889 BLAKE2B 89b20734dea44419af023b88c85b243fa3f8ac0c7272600729da8690eb53cd4286d9c9bb90e95e291644de3675a9daae63898d6621cc4c21b4fc8e0d965242b4 SHA512 43b893127b5b4f1ccd472dfe9152d4ac8f89192411d1fa6045e3ecfb5f8f16819d1cf4b6fd70d9656d25d10cafff55055da98d36d2c8537d5b07e29e2d157799
DIST jupyterlab-3.5.2.tar.gz 17111761 BLAKE2B 77c63d8842f9e58a10ed3fae3ecd9cd6b10045d3aec1e90cbc83fe40bc7d4b5cbac4eabbaac2a36c77815cd27f332a35ffdf8ea5e7fd07e95893bd5bad5c68a4 SHA512 b6a5b314fc23e4a9164085827123c19570d112519c6651453006cc18f89c1eaac74871f6e8faf9ced4c32eada72912f72b2ab3cb2ff101ef6b6e3e70601494aa
+DIST jupyterlab-3.5.3.tar.gz 17114007 BLAKE2B 70d32721a2579331dd4e3481f7241f5e2c5aad6dac851f213de0ac1fc3b76667bea496bca5ea13ee562e9678d51ac45df91c5901d8d3b7dc839977d3d842e67d SHA512 fdacd34ab629da2b5c2eb23f11ba4d44d5b27872e1736850319bcabbe635d31cfa2891c1c5991b152a5c1d94221e3766a20fc91033f556d8e508374bc46d5fe2
EBUILD jupyterlab-3.5.0.ebuild 2533 BLAKE2B 79b652defc11ca8cff256c039a0a368f5ccef972b1fe558a6ff6cd2cb7dfd82455eceadd7ab872e27a8a3e036b16e09a913a8f1a46d86b6e73470ed8ec6f7081 SHA512 c417e13d94d7a6dca79f36b138638a48867ac83b874c8ba80a145c04ebf8f0a2b720b837b694e9d661748e07e9f662cdb3177d9c1888221efa7c2718967813bc
EBUILD jupyterlab-3.5.2.ebuild 2578 BLAKE2B 85d3333e7f7a64374577858c6dcb13101a4bd43bd291f80136f53e174ca06157b2f8e9a191c0e0ee1899206c8e452186bc633183722be146f29552e6d6f2bf91 SHA512 0946241f0f7c11b306b8e36952a7dfb31478598770cc3374fff3a008cdd8bb43f947f1ea1ea1e9dc8e1ebbe41dadba67bfdf36c92f92465a1bd8df2d3549a4a5
+EBUILD jupyterlab-3.5.3.ebuild 2623 BLAKE2B 5a31b2cadf9398c5ba6c5273f25dcf0ce8921f9e28b2f3ff8e0eb9a335f779608d26f64860ec120da1aa85ce14a48c21f4cb37dc50e3780def58e40f026a1e79 SHA512 625279bc464242757e4481431bbcb9cd6ed6514333da1502256530a0557640ff7c4afc7ca5796a42fc2d7d282af50a1626a2c99884d3c0a0cd97f7483e8dcd25
MISC metadata.xml 412 BLAKE2B f0b40e19f8ba9dc116f0e4a882cabab6376f22d1eaeb3eac58ecff465ee2aff3564ddbf55e4ffb8971807a39945109a164037a954419671a274d3ac558b102ea SHA512 b6149a03585ca04bc3bf6f3ea6055e8e1fcb620a771359d150df7c22ee16bf09f57c8037df2161021fac0c194be0ac5ec79a31f0511d785e0c5b1ca96d817e42
diff --git a/dev-python/jupyterlab/jupyterlab-3.5.3.ebuild b/dev-python/jupyterlab/jupyterlab-3.5.3.ebuild
new file mode 100644
index 000000000000..d6b258d2dcd4
--- /dev/null
+++ b/dev-python/jupyterlab/jupyterlab-3.5.3.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=jupyter
+
+inherit distutils-r1
+
+DESCRIPTION="JupyterLab computational environment"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyterlab/jupyterlab/
+ https://pypi.org/project/jupyterlab/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD MIT GPL-3 Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/ipython[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/jupyter_core[${PYTHON_USEDEP}]
+ >=dev-python/jupyterlab_server-2.10[${PYTHON_USEDEP}]
+ >=dev-python/jupyter_server-1.16[${PYTHON_USEDEP}]
+ >=dev-python/nbclassic-0.2[${PYTHON_USEDEP}]
+ <dev-python/notebook-7[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.1[${PYTHON_USEDEP}]
+ >=dev-python/tornado-6.2[${PYTHON_USEDEP}]
+ dev-python/tomli[${PYTHON_USEDEP}]
+ net-libs/nodejs
+"
+
+BDEPEND="
+ test? (
+ dev-python/check-manifest[${PYTHON_USEDEP}]
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/jupyterlab_server[${PYTHON_USEDEP}]
+ dev-python/openapi-core[${PYTHON_USEDEP}]
+ dev-python/openapi-spec-validator[${PYTHON_USEDEP}]
+ dev-python/pytest-console-scripts[${PYTHON_USEDEP}]
+ dev-python/pytest_jupyter[${PYTHON_USEDEP}]
+ dev-python/pytest-tornasync[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ dev-python/requests-cache[${PYTHON_USEDEP}]
+ dev-python/strict-rfc3339[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_DESELECT=(
+ # These tests call npm and want internet
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_uninstall_core_extension
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_install_and_uninstall_pinned_folder
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_install_and_uninstall_pinned
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_build_custom_minimal_core_config
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_build_custom
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_build_check
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_build
+ jupyterlab/tests/test_build_api.py::TestBuildAPI::test_clear
+ jupyterlab/tests/test_build_api.py::TestBuildAPI::test_build
+)
+
+distutils_enable_tests pytest
+# TODO: package sphinx_copybutton
+#distutils_enable_sphinx docs/source dev-python/sphinx_rtd_theme dev-python/myst_parser
+
+python_install_all() {
+ distutils-r1_python_install_all
+ mv "${ED}/usr/etc" "${ED}/etc" || die
+}