summaryrefslogtreecommitdiff
path: root/dev-python/jupyterlab-lsp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-18 08:07:22 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-18 08:07:22 +0000
commit88a7ab8599213acca9dd34eb21748ff54d7c190a (patch)
tree7b0906984ae3d3754da31f07f7c730f719d2f92a /dev-python/jupyterlab-lsp
parent942c9977e0273ee6c6bd3f9822263aaeab1b69a5 (diff)
gentoo auto-resync : 18:01:2024 - 08:07:22
Diffstat (limited to 'dev-python/jupyterlab-lsp')
-rw-r--r--dev-python/jupyterlab-lsp/Manifest2
-rw-r--r--dev-python/jupyterlab-lsp/jupyterlab-lsp-5.0.2.ebuild26
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/jupyterlab-lsp/Manifest b/dev-python/jupyterlab-lsp/Manifest
index ef53a19a170a..713711ca17ad 100644
--- a/dev-python/jupyterlab-lsp/Manifest
+++ b/dev-python/jupyterlab-lsp/Manifest
@@ -1,3 +1,5 @@
DIST jupyterlab-lsp-5.0.1.tar.gz 755832 BLAKE2B d8082aaf9c1219fedeebd6a717b81f08a7bba2a8618dc99b2ecf9a6d28c4e6cbf34b711c4fae4a847675ea05d2dc7acd0c812a772e9d51f37f563d088398c088 SHA512 7fef1ab7309978aa9185afdc895a7adefc72210842228d055150b231b70980e772abf166762820971f653cf0f5abd65e9bdfe3a206c4aed99b4586fec684399e
+DIST jupyterlab-lsp-5.0.2.tar.gz 757169 BLAKE2B e1d7b26805264c570275e021ac2c4af688c70c428b0966c4f6fb75f890be55b1543602f93e6565f6ade485bec6b3d5f8d680c73c07b3f069f25990a6ad633b2b SHA512 f2826cd4d940855814d2f7cb7a07eaf4c9fb8d8440fd1f27b381804ee2c892f00461d49166e90fb8f7aa3eae64aa873973369ba56a1e484f349aab7c05d0dbc6
EBUILD jupyterlab-lsp-5.0.1.ebuild 610 BLAKE2B a3a22db791094f4bcb0dc6bd27cc542e11de8eb983b3aef6242e074ac5fb215629dd03d5fa86603e68669c23989225f63e7faff406819aeffb4126f169b64464 SHA512 7022cddb4d094b00c5e0ce341ebc38aced71410aba3f2ce1d0add8ade31d27c3b2caa930d7d394153d49ae0f1429d9e5426b633303215b39367d589fcd020078
+EBUILD jupyterlab-lsp-5.0.2.ebuild 610 BLAKE2B b16ec1dd4c48c363f7bc80677004a6cb2bae44b5cd2cb98c46141f6dbb8092eb505e9dc433d8807c53a31c47129df4e3911799eaad391678166fffe44075bed0 SHA512 19260535774c96dd83c266db21e4a501c9f4ba775894e95fc4eecf6bebf122f654dfe2a1a138ae80cb8469fbd733d2bfc7a2d4c30cb24fc95ae8b1a2f0492c80
MISC metadata.xml 421 BLAKE2B cbd9c4e3ce5848ed3d0e57832082dd730d2d16a286070639602b8fcd49c49714e7f17b220251b9f16d9c5105248933390b152c060c68522d2c82b1958b09b116 SHA512 97ac68ac4e6920f23120a5818b4404fa0b510b165a44a6455a7bf76edfa298ca137f50bd9c1a87044253f5b873f881362c2667261a4c7fdb182a7d37325520b3
diff --git a/dev-python/jupyterlab-lsp/jupyterlab-lsp-5.0.2.ebuild b/dev-python/jupyterlab-lsp/jupyterlab-lsp-5.0.2.ebuild
new file mode 100644
index 000000000000..d87eafa065c7
--- /dev/null
+++ b/dev-python/jupyterlab-lsp/jupyterlab-lsp-5.0.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Coding assistance for JupyterLab with Language Server Protocol"
+HOMEPAGE="
+ https://github.com/jupyter-lsp/jupyterlab-lsp/
+ https://pypi.org/project/jupyterlab-lsp/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/jupyterlab-4.0.0[${PYTHON_USEDEP}]
+ <dev-python/jupyterlab-5.0.0[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-lsp-2.0.0[${PYTHON_USEDEP}]
+"