summaryrefslogtreecommitdiff
path: root/dev-python/jupyterlab-lsp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-15 22:00:32 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-15 22:00:32 +0100
commit4fe36de7142d972c061813e413f66ed4bcfc38d0 (patch)
treef95577c134cc26bf3d7223b38b8c76311d57fc12 /dev-python/jupyterlab-lsp
parent2e4d96d87e04d8b2164f764dee727cd9057cf88d (diff)
gentoo auto-resync : 15:10:2023 - 22:00:32
Diffstat (limited to 'dev-python/jupyterlab-lsp')
-rw-r--r--dev-python/jupyterlab-lsp/Manifest4
-rw-r--r--dev-python/jupyterlab-lsp/jupyterlab-lsp-5.0.0.ebuild (renamed from dev-python/jupyterlab-lsp/jupyterlab-lsp-4.2.0.ebuild)12
2 files changed, 10 insertions, 6 deletions
diff --git a/dev-python/jupyterlab-lsp/Manifest b/dev-python/jupyterlab-lsp/Manifest
index 8ff65c4b731d..cdf9344dc334 100644
--- a/dev-python/jupyterlab-lsp/Manifest
+++ b/dev-python/jupyterlab-lsp/Manifest
@@ -1,3 +1,3 @@
-DIST jupyterlab-lsp-4.2.0.tar.gz 871193 BLAKE2B e3486f8e3dcdd534aa19209b936f6b2579c827a728fd080150fb6d31968bc1cd5b4c11b94e22e229eeaf6ac3953b473b89d66974d8f96bc9bc89fdf916d1c501 SHA512 4bd73f4d2e6a4823ad9649dcad4ac6e5de2626ef53fad13027de3a37cd6af5aa60dd707b93a599f41cdc4f7ea7b62a3ca473703f65e6a8038f8d7df62365aefe
-EBUILD jupyterlab-lsp-4.2.0.ebuild 562 BLAKE2B 5515e2b9ce4a942aaf15515f82ecc03f2ef667fc9072ba13c49c4571308bfb06a6c15696bb9be6511df761c02a078819b621db663fc619013d8eb5293dc467a8 SHA512 3012407d81591318ff1d57379b4363e8c5600307f5f200ecc4ab465529cd91195fc43d5a6ff69ed10b22fc63d2653557316f1d94b7feefbaff872d343fc32b8b
+DIST jupyterlab-lsp-5.0.0.tar.gz 753429 BLAKE2B bd9fac94edea990943ce839c773270f14a5afd646b312c3c6888a0230c2846968388862c01c4954830d85c3eebcd6699aed79cc7861e4fb8d19d576cf0ba938b SHA512 a6e586cf19707a6aec91f495fbb437ce2aaa6b827964c06d4479d056b0a8eca525c46a3e3e8c7891e0f486cde9b63416a80188c623f71948e4b1658a751d98b1
+EBUILD jupyterlab-lsp-5.0.0.ebuild 610 BLAKE2B eec333ee45a97b0b9b05b784c39886730a5873b09afcde0798321252af717cf3d0c0971ddc6175b8eac1559acc931423bd609b2f1b49a542d7abdb15a8ead16a SHA512 4ccfef9942c5338f604220516416184b1aa0d49d39b4c803b7e084fdb82d27c270b1d4434b33ad7139199757303fd4cbd981f8600306921b50a1c1528849e515
MISC metadata.xml 421 BLAKE2B cbd9c4e3ce5848ed3d0e57832082dd730d2d16a286070639602b8fcd49c49714e7f17b220251b9f16d9c5105248933390b152c060c68522d2c82b1958b09b116 SHA512 97ac68ac4e6920f23120a5818b4404fa0b510b165a44a6455a7bf76edfa298ca137f50bd9c1a87044253f5b873f881362c2667261a4c7fdb182a7d37325520b3
diff --git a/dev-python/jupyterlab-lsp/jupyterlab-lsp-4.2.0.ebuild b/dev-python/jupyterlab-lsp/jupyterlab-lsp-5.0.0.ebuild
index f8fbb2f8f9b2..b0adc310291b 100644
--- a/dev-python/jupyterlab-lsp/jupyterlab-lsp-4.2.0.ebuild
+++ b/dev-python/jupyterlab-lsp/jupyterlab-lsp-5.0.0.ebuild
@@ -3,20 +3,24 @@
EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
DISTUTILS_USE_PEP517=setuptools
PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+
inherit distutils-r1 pypi
DESCRIPTION="Coding assistance for JupyterLab with Language Server Protocol"
-HOMEPAGE="https://github.com/jupyter-lsp/jupyterlab-lsp"
+HOMEPAGE="
+ https://github.com/jupyter-lsp/jupyterlab-lsp/
+ https://pypi.org/project/jupyterlab-lsp/
+"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64"
RDEPEND="
- >=dev-python/jupyterlab-3.6.0[${PYTHON_USEDEP}]
- <dev-python/jupyterlab-4.0.0[${PYTHON_USEDEP}]
+ >=dev-python/jupyterlab-4.0.0[${PYTHON_USEDEP}]
+ <dev-python/jupyterlab-5.0.0[${PYTHON_USEDEP}]
>=dev-python/jupyter-lsp-2.0.0[${PYTHON_USEDEP}]
"