summaryrefslogtreecommitdiff
path: root/dev-python/jupyter_server
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-27 09:09:50 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-27 09:09:50 +0100
commit2be230a2a252e8e744f11a8b38e9a0097ddc9b25 (patch)
treec7c6cd81169223a110c28f74dfc1b82b3f52bcb1 /dev-python/jupyter_server
parent8d3ae5c288a62253ed3bc3d71336bf2061cfdb51 (diff)
gentoo auto-resync : 27:09:2022 - 09:09:50
Diffstat (limited to 'dev-python/jupyter_server')
-rw-r--r--dev-python/jupyter_server/Manifest2
-rw-r--r--dev-python/jupyter_server/jupyter_server-1.19.0.ebuild76
2 files changed, 78 insertions, 0 deletions
diff --git a/dev-python/jupyter_server/Manifest b/dev-python/jupyter_server/Manifest
index b18d120d87ae..be28fac2667a 100644
--- a/dev-python/jupyter_server/Manifest
+++ b/dev-python/jupyter_server/Manifest
@@ -1,3 +1,5 @@
DIST jupyter_server-1.18.1.tar.gz 451117 BLAKE2B ac9088f8f5c5afa6455f41b4006c0d49286006574101b42dd8e28501c97dcf10d7ee534d54b8cf26a8f34c7d2ba446485ce273ce04e22c39a22e5346d55ea4f5 SHA512 7acf101f337af903318de263dcf78cf3b45b799bb6095bc79568fde7f3f56ca508d39a1d40ffe2a4ab0bdc0173f0ee2f4a7426f41e0855c1b7f9dfd86f7e6d73
+DIST jupyter_server-1.19.0.tar.gz 453227 BLAKE2B c411ea965bd1948cfff488be278e9d6d4374482f0017e8e6f0b557628f1b571735008db3217035344ee1d38bed45e9c74c16fb365899408e0565d31740ee1a78 SHA512 ba1316418662bf465f5252de97efa58ecea237b51dfd83b17643176f95382d47759b88a2a79945e6bbf688dcdb3f99d091a035ab0a8a04706c6e6ba0c8a7fcc8
EBUILD jupyter_server-1.18.1.ebuild 2275 BLAKE2B 6249b549811fe6c9ab2713962068b4ce74f4a4427ced95919bda24ff9d86ffcb89016b00876ed6b627f34dd84121bddb1edb6c75bf8501df8711bde39f93d431 SHA512 47c26f3e524fc559162f27e05980965a6d5520ffd7a0ef7e6479afb2a312e2fabff2c06050d6ea20e283effe5af261b9fe9ca9c9d9c51e9afdc89e6452701528
+EBUILD jupyter_server-1.19.0.ebuild 2283 BLAKE2B 80c0a313006573fa093a6affab31a0d5beca7bc80b68ad5ba3fd3fa880b79d8102cdba23fdb83199d714eff9949f9abe4a119e2605076cfbb4c652fa6f5334ab SHA512 b18f75a8ac687e70e0dc65cef7239a10731a24f4630aa276ffb921c00eb8e766eed0b438fea2052f19982f74c0402de0ff6e8dfa986c5a3b2e5042ed26de73ac
MISC metadata.xml 544 BLAKE2B ec5a0aea1d2ad6ce0e59972d2ef4ce62c03877d464dfdc34bcb94a7d01304c63761c6bc30ed973bba1f4100e25f70541bed4eea858deb44f359d0e373ae1ade0 SHA512 ffe7deb7349ce99890b902a225b73913185bfa860237dea8c1a508a6a5e84bbb74ca7a5c43253c9986f97fb3fd1e9f2bb63ca60f73953fcc851359df8adb5fbd
diff --git a/dev-python/jupyter_server/jupyter_server-1.19.0.ebuild b/dev-python/jupyter_server/jupyter_server-1.19.0.ebuild
new file mode 100644
index 000000000000..296736ccc44c
--- /dev/null
+++ b/dev-python/jupyter_server/jupyter_server-1.19.0.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=jupyter
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Core services, APIs, and REST endpoints to Jupyter web applications"
+HOMEPAGE="https://jupyter.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/anyio-3.1.0[${PYTHON_USEDEP}]
+ <dev-python/anyio-4[${PYTHON_USEDEP}]
+ dev-python/argon2-cffi[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ >=dev-python/jupyter_client-6.1.1[${PYTHON_USEDEP}]
+ >=dev-python/jupyter_core-4.7.0[${PYTHON_USEDEP}]
+ >=dev-python/nbconvert-6.4.4[${PYTHON_USEDEP}]
+ >=dev-python/nbformat-5.2.0[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/prometheus_client[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-17[${PYTHON_USEDEP}]
+ dev-python/send2trash[${PYTHON_USEDEP}]
+ >=dev-python/terminado-0.8.3[${PYTHON_USEDEP}]
+ >=dev-python/tornado-6.1[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-5.1[${PYTHON_USEDEP}]
+ dev-python/websocket-client[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/pytest-console-scripts[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/pytest-tornasync[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ dev-python/pydata-sphinx-theme \
+ dev-python/myst_parser \
+ dev-python/ipython \
+ dev-python/sphinxemoji \
+ dev-python/sphinxcontrib-github-alt \
+ dev-python/sphinxcontrib-openapi
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # This fails if your terminal is zsh (and maybe other non-bash as well?)
+ tests/test_terminal.py::test_culling
+ tests/test_terminal.py::test_terminal_create_with_cwd
+ tests/test_terminal.py::test_terminal_create_with_relative_cwd
+)
+
+src_prepare() {
+ # disable npm use
+ sed -i -e '/\[tool\.jupyter-packaging\.builder\]/,+1d' pyproject.toml || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest \
+ -p pytest_tornasync.plugin \
+ -p jupyter_server.pytest_plugin \
+ -p pytest_console_scripts \
+ -p pytest_timeout
+}