summaryrefslogtreecommitdiff
path: root/dev-python/jupyter_core
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
commitc8d60dada2ec8eb48b2d2b290cd6683ccec40e39 (patch)
treec44943ee0563a3fa957716de909fed683117fcb9 /dev-python/jupyter_core
parent69051588e2f955485fe5d45d45e616bc60a2de57 (diff)
gentoo (valentine's day) resync : 14.02.2021
Diffstat (limited to 'dev-python/jupyter_core')
-rw-r--r--dev-python/jupyter_core/Manifest2
-rw-r--r--dev-python/jupyter_core/jupyter_core-4.7.1.ebuild42
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/jupyter_core/Manifest b/dev-python/jupyter_core/Manifest
index 95cad4b26b2b..7d19304a9cca 100644
--- a/dev-python/jupyter_core/Manifest
+++ b/dev-python/jupyter_core/Manifest
@@ -1,3 +1,5 @@
DIST jupyter_core-4.6.3.tar.gz 67305 BLAKE2B 7c6a32bd8ce773b7bc4156eabf75597112716632179736b19be4b0e73eba7c5c67a0c9d2d141b952d72b68aff826227b0004a3bc9f3b286b68eb1375f2316bdb SHA512 3c7370c24a4cf53c9747e9e411852d207c0c7035809dab7cb018ccb53e19208df25ad4f728531e47f3a42c4d9694c3e1ed7b03133de23bcbdeb346c319f5f51f
+DIST jupyter_core-4.7.1.tar.gz 68886 BLAKE2B aa89351845c669474c03a307934a5d84b6357679bc99f2fc7da4f93ff347766d52ce3551780803b73941d6457f7004306e795398fd390c81e9180193a2119225 SHA512 bc190abd000566dbd097dcb14acf1926c92bb265f2cfbbd14dac6a9cf7d6a02f924ba89fa957ca30c2af57433e9187e288bb8e80d039a3d3a583c6e488a9c80e
EBUILD jupyter_core-4.6.3-r1.ebuild 873 BLAKE2B c12862c168695134a8c52a77060095a2b9561cc63ac212267cc91116144466b22d89accb0e0e48309c359017c9de14f15c42404d2ce210258ad0a44798fe19e9 SHA512 bbbc98f07bd98aad3d0a719ebc1c0a0b398138fdac6c259c886dd502950db26508a8da010802367dddaec04d7744e037e3e8dae272d478a20c3b07897bb9825f
+EBUILD jupyter_core-4.7.1.ebuild 1041 BLAKE2B d293bb8833b7e69d946c7428a57668c2ff058199128fb590ef631f136186d6735ca7333755890b46f3c09a2738c08cfad2a22d490d590a31fb0dc09b52a610d8 SHA512 f961279743b7cb4e630fcc195cdd26e72d3ab471425aec6208ef0e90f391d412d6eda3a2f1cae2c615e9c2062071eebe4c75f92c8699213f79e023f4fe685291
MISC metadata.xml 733 BLAKE2B b53498df76d4e2adf05087c94920897408001e3852dd2d600f7f08748c09e8248d2d2be301ef7691db2ef1768369d935cfb3d03bf0dce44db8f0b8e98539037d SHA512 a828f64941f7f50c82af438692a21614115df2f151064cc684ddda16c6a7dad674efc2563a68dd6b01ca9edaf07c6d2e54a1ae6803f72bfa9e5e14995c4ca37f
diff --git a/dev-python/jupyter_core/jupyter_core-4.7.1.ebuild b/dev-python/jupyter_core/jupyter_core-4.7.1.ebuild
new file mode 100644
index 000000000000..3ee1504526a9
--- /dev/null
+++ b/dev-python/jupyter_core/jupyter_core-4.7.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Core common functionality of Jupyter projects"
+HOMEPAGE="https://jupyter.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="dev-python/traitlets[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ >=dev-python/ipython-4.0.1[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinxcontrib-github-alt
+distutils_enable_tests pytest
+
+python_test() {
+ local deselect=(
+ # fails if jupyter is not in system sitedir
+ # (PYTHONPATH is insufficient)
+ jupyter_core/tests/test_command.py::test_not_on_path
+ jupyter_core/tests/test_command.py::test_path_priority
+ # TODO
+ jupyter_core/tests/test_paths.py::test_jupyter_path_prefer_env
+ )
+
+ pytest -vv ${deselect[@]/#/--deselect } ||
+ die "Tests failed with ${EPYTHON}"
+}