summaryrefslogtreecommitdiff
path: root/dev-python/jupyter_core/jupyter_core-4.11.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-21 14:02:42 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-21 14:02:42 +0100
commit5560910b8e280aa828f26c34b4e361b44f5227c4 (patch)
tree2abdaf1f2d47833722c546232baa3780b006df0d /dev-python/jupyter_core/jupyter_core-4.11.2.ebuild
parentf1269e587f3d88b85f72a6fbaf727da5d6c9af90 (diff)
gentoo auto-resync : 21:10:2022 - 14:02:42
Diffstat (limited to 'dev-python/jupyter_core/jupyter_core-4.11.2.ebuild')
-rw-r--r--dev-python/jupyter_core/jupyter_core-4.11.2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/jupyter_core/jupyter_core-4.11.2.ebuild b/dev-python/jupyter_core/jupyter_core-4.11.2.ebuild
new file mode 100644
index 000000000000..f7de21236410
--- /dev/null
+++ b/dev-python/jupyter_core/jupyter_core-4.11.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Core common functionality of Jupyter projects"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter/jupyter_core/
+ https://pypi.org/project/jupyter-core/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/traitlets[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/ipython-4.0.1[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinxcontrib-github-alt
+distutils_enable_tests pytest