summaryrefslogtreecommitdiff
path: root/dev-python/jupyter_console/jupyter_console-6.4.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-python/jupyter_console/jupyter_console-6.4.3.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-python/jupyter_console/jupyter_console-6.4.3.ebuild')
-rw-r--r--dev-python/jupyter_console/jupyter_console-6.4.3.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/jupyter_console/jupyter_console-6.4.3.ebuild b/dev-python/jupyter_console/jupyter_console-6.4.3.ebuild
new file mode 100644
index 000000000000..44cbdde53ded
--- /dev/null
+++ b/dev-python/jupyter_console/jupyter_console-6.4.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A terminal-based console frontend for Jupyter kernels"
+HOMEPAGE="https://jupyter.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/ipython[${PYTHON_USEDEP}]
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ >=dev-python/jupyter_client-7.0.0[${PYTHON_USEDEP}]
+ <dev-python/prompt_toolkit-3.1.0[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]"
+# util-linux provides script(1)
+BDEPEND="
+ test? (
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ sys-apps/util-linux
+ )"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinxcontrib-github-alt dev-python/sphinx_rtd_theme
+distutils_enable_tests pytest