summaryrefslogtreecommitdiff
path: root/dev-python/jupyter_client
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-02 14:09:07 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-02 14:09:07 +0100
commitb17a3ef12038de50228bade1f05502c74e135321 (patch)
tree9026dffec53f92cba48ca9a500a4f778e6304380 /dev-python/jupyter_client
parent3cf7c3ef441822c889356fd1812ebf2944a59851 (diff)
gentoo resync : 02.09.2020
Diffstat (limited to 'dev-python/jupyter_client')
-rw-r--r--dev-python/jupyter_client/Manifest1
-rw-r--r--dev-python/jupyter_client/jupyter_client-6.1.6-r2.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/jupyter_client/Manifest b/dev-python/jupyter_client/Manifest
index 5df1b199413a..5ef7be174798 100644
--- a/dev-python/jupyter_client/Manifest
+++ b/dev-python/jupyter_client/Manifest
@@ -2,4 +2,5 @@ DIST jupyter_client-6.1.5.tar.gz 290829 BLAKE2B 7029703ebf7dccafd9c90835d9ed3305
DIST jupyter_client-6.1.6.tar.gz 292265 BLAKE2B 46f5b814577c8b1351ce42eb3de4a3032bb2917512f0c9cfc07fddc991698e192b628c03a9ce0d98817dfebcf4af0386fa4ee656b524f54c36de64781af3b8dd SHA512 9a443a2b4a86d823d1403a05d359b50ca95efb8e1dd992d331699e3fe2b46e5d4190cc55aa5d110a384fc0bb94abceaa4e36f67c0f7ce5a33f9ef3b11e682522
EBUILD jupyter_client-6.1.5.ebuild 849 BLAKE2B 49328d173ac8e7f13e98e0479785d607bbcdf92de3b3642f94e3fb6737f4162debc0defd27043705212585aa8aaa4c48fc674bce6b36eb3cfc929b61626e544c SHA512 f527f2ab63ef66b74f6540db12896bc0a0ff0d3af5c4f82bece768c87471b810e592cf29e075e30372840b0408ac00593670b1602a88a7c5270d5420800af134
EBUILD jupyter_client-6.1.6-r1.ebuild 884 BLAKE2B 17c74179956421da4617e2a4058dc05fced9860412c2142c0df8fd07cd7d7559cbf1224937fea1c7404ecee468bf9286440ec33809338e3386e46c603baa289d SHA512 1f1afa7805b4fba979bce7dc9ca34aafbe8c8d35bf6a0e54450e9b1cfcde2bfb7c72e01fbfcc02fab62f91d657e2b738048095f8ab55cfa829e82585d351189d
+EBUILD jupyter_client-6.1.6-r2.ebuild 884 BLAKE2B cb9f675ea4cb1e5d1fb26ceea1b665e8aa172cabe1d63d02121628e2c1f5f32cd48b03125b081212ccd412e0fe79922b7ce6506dcd0445cd26d1195cb7020436 SHA512 ef176b816fde521e550a5d27bd36e666983d6dc57de697d97f71c3849c855086d60b424f15d85be6fa99a12db4d51c859e289a6770f1a9f100d95494e55e159f
MISC metadata.xml 779 BLAKE2B 43107b0b7e5e1316a386e41e99c482dd13eb753bcaeebf6b496d7b432b69aaee01f6777877033154b178b17bbef87cb019d4fc55302e089c69972ec7dd412c59 SHA512 4333a7a7ae831d4f12b09d3f78fea784c508ed1de502b71d5279c6574cec7808e0e13e0e9b59d3b6048788d406f617a883f753204eaa22c24218587e3e4fd610
diff --git a/dev-python/jupyter_client/jupyter_client-6.1.6-r2.ebuild b/dev-python/jupyter_client/jupyter_client-6.1.6-r2.ebuild
new file mode 100644
index 000000000000..85d8a9afd7bc
--- /dev/null
+++ b/dev-python/jupyter_client/jupyter_client-6.1.6-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_REQ_USE="threads(+)"
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Jupyter protocol implementation and client libraries"
+HOMEPAGE="https://jupyter.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/async_generator[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/traitlets[${PYTHON_USEDEP}]
+ dev-python/jupyter_core[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-14.4.0[${PYTHON_USEDEP}]
+ www-servers/tornado[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/ipython[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest