summaryrefslogtreecommitdiff
path: root/dev-python/jupyter_client
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-03 22:39:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-03 22:39:47 +0100
commit7f0ccc917c7abe6223784c703d86cd14755691fb (patch)
tree8c6793f68896b341e22f33d7e6cef88e481f4a8b /dev-python/jupyter_client
parent9aa80713372911cec499b3adb2cd746790920916 (diff)
gentoo resync : 03.07.2021
Diffstat (limited to 'dev-python/jupyter_client')
-rw-r--r--dev-python/jupyter_client/Manifest2
-rw-r--r--dev-python/jupyter_client/jupyter_client-6.1.12.ebuild16
2 files changed, 12 insertions, 6 deletions
diff --git a/dev-python/jupyter_client/Manifest b/dev-python/jupyter_client/Manifest
index dfc0a2fec1b1..342fa8e8091c 100644
--- a/dev-python/jupyter_client/Manifest
+++ b/dev-python/jupyter_client/Manifest
@@ -1,3 +1,3 @@
DIST jupyter_client-6.1.12.tar.gz 301499 BLAKE2B 8041b84ad2e89413ee60d1aee2e49a67a89b5aad1c3118c8fa7d7d719c8ec2acbc72278c9aaea095cdcb89235800d09b1792b2138c09a4aad59ceaaf695af431 SHA512 f31ff1a24b264c32d35d07491785e1d77935cdb463243e90e4aadcb0a093a074cdce75f01662591766588f39b146077639ca697f71157309dc92f12ae04d5cdd
-EBUILD jupyter_client-6.1.12.ebuild 928 BLAKE2B d163a3423c14ec3007f7fcc16082947c374f9f1ce42067ad834a70259b95d19d35899e57596f91519b6263f42a82cb21a56939efc576ce1d3e50645e711b0371 SHA512 c3c94cd19e8882aaecb928d4f51b552d1021a744273ef1d888f825f8a480a618e80d9ffd51328c98fae305e0208b133ead8b665fdd23d4321dd5ea0951aab1dc
+EBUILD jupyter_client-6.1.12.ebuild 1180 BLAKE2B a43eb0b87166422d29e352b1d24a03cf90d826cb51b80f29c123419d076bbd245acd540f5187788a7169d589137162a3070890f20872635fe8e243782492fe73 SHA512 b848334050e8308a5d6a83f69bed43168fc3a7427c139909db4a21b1ed178a627c06b461a0d2f43f8abc73e64e0a9b0d7173612d4e5a99d0e9169efbb11e1e86
MISC metadata.xml 779 BLAKE2B e9744283eb51cd9df5ca7a65a29d80e7712e22a1c4f039bac233a4301a821bbf616a59bc5f923dca0edfc16e32fee9a676a6aa90fd8011beaeca68ee97d63355 SHA512 3e07a943513fb5d2d0e689572c39084c63ef2b54503843897dc1492adbd9fb217a3a26931e48f2bef2fbb99e32900aec85968a9597ddf54350e174ccd82a7b4b
diff --git a/dev-python/jupyter_client/jupyter_client-6.1.12.ebuild b/dev-python/jupyter_client/jupyter_client-6.1.12.ebuild
index 8743d8a22758..b5a1d4b89ec7 100644
--- a/dev-python/jupyter_client/jupyter_client-6.1.12.ebuild
+++ b/dev-python/jupyter_client/jupyter_client-6.1.12.ebuild
@@ -1,12 +1,10 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
PYTHON_REQ_USE="threads(+)"
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
inherit distutils-r1
DESCRIPTION="Jupyter protocol implementation and client libraries"
@@ -15,7 +13,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~sparc x86"
+KEYWORDS="amd64 ~arm arm64 ~riscv ~sparc x86"
RDEPEND="
dev-python/async_generator[${PYTHON_USEDEP}]
@@ -33,3 +31,11 @@ BDEPEND="
)"
distutils_enable_tests pytest
+
+python_test() {
+ local deselect=(
+ jupyter_client/tests/test_kernelmanager.py::TestAsyncKernelManager::test_signal_kernel_subprocesses
+ jupyter_client/tests/test_kernelmanager.py::TestAsyncKernelManager::test_start_new_async_kernel
+ )
+ epytest ${deselect[@]/#/--deselect }
+}