summaryrefslogtreecommitdiff
path: root/dev-python/jupyter
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-05-07 11:18:59 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-05-07 11:18:59 +0100
commita2810985afabcc31d3eace5e61d8ea25b852ba17 (patch)
treed254e77a7aeadd875db2dc73532da78094238ffd /dev-python/jupyter
parenteab5731cdf11d4ae8cdf111461d46fd96c5bdd37 (diff)
gentoo resync : 07.05.2019
Diffstat (limited to 'dev-python/jupyter')
-rw-r--r--dev-python/jupyter/Manifest1
-rw-r--r--dev-python/jupyter/jupyter-1.0.0-r2.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/jupyter/Manifest b/dev-python/jupyter/Manifest
index bb858ec852ee..d3ce36cf8819 100644
--- a/dev-python/jupyter/Manifest
+++ b/dev-python/jupyter/Manifest
@@ -1,5 +1,6 @@
DIST jupyter-1.0.0-file-colision.patch 1727 BLAKE2B 59bf5e567e6da9e9f3d84178942993072e1697c1c4c06e06d606dce7bdc76d296d10c30cdef2865bce7b4c26136a1b0a2860f009f1530c1815b48b3300401501 SHA512 a6b4cc6b91bb9941f029963cc3e3b7f415192f64788a34dde7828d450497987f92c25655c5ca183a7408fb1fb439917ba0f0a1ef1db3fe3bec1fc46d9ad2cf4d
DIST jupyter-1.0.0.tar.gz 12916 BLAKE2B 36476eaf0119613ba6d9f153aab1658f43951dc3879cb6a9e90d8fba14cc1247305e18fda2251127faac4e68867efd3ef57129675bbe89a17a6469255efcade2 SHA512 1f0bc83f7a127c98ccf4b3868814116aa272ea5d0baac52d7a022305af7e2da28ca2b90fa3554ff085d8df3eb6d8b8cde80bf02b8e66064c59900b926d73c520
EBUILD jupyter-1.0.0-r1.ebuild 1298 BLAKE2B 6ec6c6dc466fa2f2aca6d1777a07ac74f58972e1fcca6e78f98c8cdfbde68b1d5d4e44526671644a3211065ea4b791c91372ca1cbf265e376f8af2a13fb2f3cc SHA512 79fe7b6ca66447bf31e0868b160ace51dcb4dc8774db51272234dbc8918185083de35237856e4223eadc9e0249bc270fa710dae317296a056190cc1c9ecf84ab
+EBUILD jupyter-1.0.0-r2.ebuild 1288 BLAKE2B d449cdcf51fca9dd3e6fc7103947e69b5fde877d98c8df09ea4ad7224bb1742d0d7a3f561caa08c475974cdcbe0bb6b4f39e0b13b6ad5282d1d836de64d3e713 SHA512 28ac8c0fbf26c70d262a0c69b4f23ff661c398f363fe5afa31b24360c7da87ed83333a0b1eb52acb278409cb201b1712edbc25bcaa5cd02b77ff21ea0172ab5d
EBUILD jupyter-1.0.0.ebuild 1069 BLAKE2B 8ebdbf05a5a0e1fe1cee60f30d736cb11b3d223afeff0af96e1aad39ac7429014186f0b1b189c88735c0ce3d14c9104cc878eb15a6e26ca8ea472a7ac720bf9e SHA512 fb4b3d65f7b2d33214811dd353eb78c9efe271e6e5ad54f907b62ab604eeff015fb0d15ff4ddc8da2f7c2814e14f6a6f984cc29dc6d5af60f00a48e315a4c58d
MISC metadata.xml 518 BLAKE2B 9698e2cc9423ef542d9cfb8b19be99b925a4098fa1350ad0806c384c495aca26852cedac070d7b83db27444413f72e201f7daac1ce30d05bffc09ac8270b2d7e SHA512 3838bb1bd86e45821a6793faa2afcffa0a887876e35fd36a2b21e6e6312256f94ab79026232197752c922ad51208dbc04a30c43e0bd0ab8d7945ee4fe2947999
diff --git a/dev-python/jupyter/jupyter-1.0.0-r2.ebuild b/dev-python/jupyter/jupyter-1.0.0-r2.ebuild
new file mode 100644
index 000000000000..608399551755
--- /dev/null
+++ b/dev-python/jupyter/jupyter-1.0.0-r2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Jupyter metapackage. Install all the Jupyter components in one go"
+HOMEPAGE="https://jupyter.org"
+SRC_URI="
+ mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
+ https://patch-diff.githubusercontent.com/raw/jupyter/jupyter/pull/198.patch -> ${P}-file-colision.patch
+ "
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="
+ dev-python/notebook[${PYTHON_USEDEP}]
+ dev-python/qtconsole[${PYTHON_USEDEP}]
+ dev-python/jupyter_console[${PYTHON_USEDEP}]
+ dev-python/nbconvert[${PYTHON_USEDEP}]
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/ipywidgets[${PYTHON_USEDEP}]"
+DEPEND="doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+PDEPEND=">=dev-python/jupyter_core-4.2.0[${PYTHON_USEDEP}]"
+
+PATCHES=( "${DISTDIR}"/${P}-file-colision.patch )
+
+python_prepare_all() {
+ # Prevent un-needed download during build
+ if use doc; then
+ sed -e "/^ 'sphinx.ext.intersphinx',/d" -i docs/source/conf.py || die
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( "${S}"/docs/build/html/. )
+ distutils-r1_python_install_all
+}