summaryrefslogtreecommitdiff
path: root/dev-python/jupyter-server-proxy/jupyter-server-proxy-3.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
commit3517852e3b8a68d1e997770fc0650c5053bafc6c (patch)
tree44068672445b1418489aed82de58df3c470289e7 /dev-python/jupyter-server-proxy/jupyter-server-proxy-3.2.0.ebuild
parent0f15659d48c193027158492acb726297501202c5 (diff)
gentoo resync : 04.01.2022
Diffstat (limited to 'dev-python/jupyter-server-proxy/jupyter-server-proxy-3.2.0.ebuild')
-rw-r--r--dev-python/jupyter-server-proxy/jupyter-server-proxy-3.2.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/jupyter-server-proxy/jupyter-server-proxy-3.2.0.ebuild b/dev-python/jupyter-server-proxy/jupyter-server-proxy-3.2.0.ebuild
new file mode 100644
index 000000000000..a4387a0001ab
--- /dev/null
+++ b/dev-python/jupyter-server-proxy/jupyter-server-proxy-3.2.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Jupyter notebook server extension to proxy web services"
+HOMEPAGE="https://github.com/jupyterhub/jupyter-server-proxy"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+# The GitHub tarball includes the tests, but does not have the js stuff we need
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/aiohttp[${PYTHON_USEDEP}]
+ >=dev-python/jupyter_server-1.0[${PYTHON_USEDEP}]
+ >=dev-python/simpervisor-0.4[${PYTHON_USEDEP}]
+"
+BDEPEND="dev-python/jupyter_packaging[${PYTHON_USEDEP}]"
+
+src_install() {
+ distutils-r1_src_install
+ mv "${ED}/usr/etc" "${ED}/etc" || die
+}