summaryrefslogtreecommitdiff
path: root/dev-python/jupyter-events/jupyter-events-0.6.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-20 10:17:50 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-20 10:17:50 +0100
commit399fa07bfac673a8846466b16c76549e329b55b8 (patch)
tree29af17ef91f1bd986b8e615a96b61db7fad5df14 /dev-python/jupyter-events/jupyter-events-0.6.3.ebuild
parent388a0747e5972613060d5ca13955b5cd7132533d (diff)
gentoo auto-resync : 20:05:2023 - 10:17:50
Diffstat (limited to 'dev-python/jupyter-events/jupyter-events-0.6.3.ebuild')
-rw-r--r--dev-python/jupyter-events/jupyter-events-0.6.3.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/jupyter-events/jupyter-events-0.6.3.ebuild b/dev-python/jupyter-events/jupyter-events-0.6.3.ebuild
new file mode 100644
index 000000000000..01ada11cc180
--- /dev/null
+++ b/dev-python/jupyter-events/jupyter-events-0.6.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Jupyter Event System library"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter/jupyter_events/
+ https://pypi.org/project/jupyter-events/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86"
+
+# jsonschema[format-nongpl] deps are always on in our ebuild
+RDEPEND="
+ >=dev-python/jsonschema-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/python-json-logger-2.0.4[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.3[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-5.3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-console-scripts[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/rich[${PYTHON_USEDEP}]
+ )
+"
+
+# TODO: package jupyterlite-sphinx
+# distutils_enable_sphinx docs
+distutils_enable_tests pytest