summaryrefslogtreecommitdiff
path: root/dev-python/jupyter-core
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-27 07:43:26 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-27 07:43:26 +0000
commitd4ce53f1e327bfbbc32e193e0f495b0e826c61e5 (patch)
treeeaee0038a45a76debf2097852b1fb076440f6cbf /dev-python/jupyter-core
parenta2210d6624510ad5825191a26603b73bbc096b98 (diff)
gentoo auto-resync : 27:12:2023 - 07:43:26
Diffstat (limited to 'dev-python/jupyter-core')
-rw-r--r--dev-python/jupyter-core/Manifest2
-rw-r--r--dev-python/jupyter-core/jupyter-core-5.6.0.ebuild40
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/jupyter-core/Manifest b/dev-python/jupyter-core/Manifest
index 047a11eb37df..f3436af1db9e 100644
--- a/dev-python/jupyter-core/Manifest
+++ b/dev-python/jupyter-core/Manifest
@@ -1,5 +1,7 @@
DIST jupyter_core-5.5.0.tar.gz 85369 BLAKE2B 41fa2381023c8f2313607d2ac989d1f35dcd362abd4b9573affaf9fc34cd48eb260d2ad68af97be2d47aa4a077f1756e6e291a4f0dd48c9774df2d31dda7e9b4 SHA512 92ca5ddc69d58ecdf1f707104e950ba43c88630991b0a6951fb6ba83260573b9f48c7903b25ae7bc105c08b3179de4bebb5a87b66453b96ceed631cbf555d631
DIST jupyter_core-5.5.1.tar.gz 85962 BLAKE2B a00e96b417d86cc66ac483d031919483ded2e06da9688ed3554d96b5b6709f6ffd1d3602a63160d37c4774d37ee166aed3f3fb81f7f9882482302c8189a19fce SHA512 f82ce8a0f6671b06b6bb768d1a7cf85a9b28be57ba88809334d2fbcfed0d6e2bc5a2320a128ed8a8b498a763d157b1ecc1dc093de1c1aa97a65770a5b715c202
+DIST jupyter_core-5.6.0.tar.gz 86418 BLAKE2B 70ab01fc13772f772c374a9452f36926f43bf85c6a19108592ce91238df137116f683692a69cbbb2693a87222728b76de0d4b80563bcd5b6d9019aac874e1d91 SHA512 2a2ff1a6ecc12adbd98b1beaea6206f58fe6d24b841102a436ed42106639992454eb4af2515ff268e95749fa01c3352ac1c919bfb053f3ebe22e1d9d9f9e03d3
EBUILD jupyter-core-5.5.0.ebuild 999 BLAKE2B 8761d874fb866d45aa80dd6ac15d0afa5c46fd96efb70856b69007f0685a6e7a5ca64b9efb10f6f83f725998df88f6c4b410292b0363af4b379424b74f4e0106 SHA512 8dcb6869de00b0c46b6ed3dedcf7b42765189b83a5d8810f391ca319a86d7179063b773d760756b9509318b49f24db03ae44f29420b8a74cb1dd3c823f3cb0ba
EBUILD jupyter-core-5.5.1.ebuild 1007 BLAKE2B c4310b6694b5e5882d032574551615307f17c849a8f20ce78b65722abaf05128c6469e73727893a5e6b56db1cb5cc353e2bdeeb8b56e28bf04ea657b1252f800 SHA512 22b36acbdd6cbd416d9b32cebfe0c882a7bbc23722d98d62fa711b98facfcebe6bcd00a7bff15f0fd6778895f1a62322000f000bcdeab815aadd60527e502552
+EBUILD jupyter-core-5.6.0.ebuild 1007 BLAKE2B c4310b6694b5e5882d032574551615307f17c849a8f20ce78b65722abaf05128c6469e73727893a5e6b56db1cb5cc353e2bdeeb8b56e28bf04ea657b1252f800 SHA512 22b36acbdd6cbd416d9b32cebfe0c882a7bbc23722d98d62fa711b98facfcebe6bcd00a7bff15f0fd6778895f1a62322000f000bcdeab815aadd60527e502552
MISC metadata.xml 759 BLAKE2B 4ef6a95640943d1b082bb65ae17515300089c6d78c0aa81410f4c7e57e1447787ad15373f314f8ea5c980459f4e5f74ee54edace2eb9421991e2425793040adc SHA512 d9769460a005d11961ebabc81636065aec545166820e923ab7abd58782e0832592a58611ccb4485164ef7c1c646812e8f608fafb9639525663732dec730542f5
diff --git a/dev-python/jupyter-core/jupyter-core-5.6.0.ebuild b/dev-python/jupyter-core/jupyter-core-5.6.0.ebuild
new file mode 100644
index 000000000000..ff6b2a155d03
--- /dev/null
+++ b/dev-python/jupyter-core/jupyter-core-5.6.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Core common functionality of Jupyter projects"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter/jupyter_core/
+ https://pypi.org/project/jupyter-core/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos"
+
+RDEPEND="
+ >=dev-python/platformdirs-2.5[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-5.11.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/ipython-4.0.1[${PYTHON_USEDEP}]
+ dev-python/pip[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs \
+ dev-python/myst-parser \
+ dev-python/pydata-sphinx-theme \
+ dev-python/sphinx-autodoc-typehints \
+ dev-python/sphinxcontrib-github-alt \
+ dev-python/sphinxcontrib-spelling \
+ dev-python/traitlets
+distutils_enable_tests pytest