summaryrefslogtreecommitdiff
path: root/dev-python/jupyter-core
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-16 07:40:50 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-16 07:40:50 +0100
commitbb5caf02fffada276b5aa598b3b6faea88ca0784 (patch)
treebfa61792a9b53240a85c99f215a14731f74bdd3a /dev-python/jupyter-core
parent98dd97c6dc5b5b4ad4bb19efeb7f314cc52f43ff (diff)
gentoo auto-resync : 16:06:2023 - 07:40:49
Diffstat (limited to 'dev-python/jupyter-core')
-rw-r--r--dev-python/jupyter-core/Manifest2
-rw-r--r--dev-python/jupyter-core/jupyter-core-5.3.1.ebuild38
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/jupyter-core/Manifest b/dev-python/jupyter-core/Manifest
index 629791ddf8f0..cd7e12da46bb 100644
--- a/dev-python/jupyter-core/Manifest
+++ b/dev-python/jupyter-core/Manifest
@@ -1,3 +1,5 @@
DIST jupyter_core-5.3.0.tar.gz 83909 BLAKE2B c0e5418770a4d3527e825bcd63cb9371855f544f19493b82f49db892fc92e91fd257b07b45d7cf20760f9ac9205346b3ec533491baf45f225764e6d310524bb8 SHA512 2c63f59a9618ee01d200e233cf85d586d88976c8d545235be224f9c64a54eb3a70e8b47220cc29b8ad3c102cc6c8754c8ccff2a771899986f322def5f539e072
+DIST jupyter_core-5.3.1.tar.gz 84448 BLAKE2B 22adc8f7a0b39fa4ffd087a7c7305fa29d05d45200b69a3af6827083183292e58b3b5854b60545eb065808dffec2ae9252feb573b9450bd3014d493cb1784ed3 SHA512 752ce40c0aa71432177100f34596ad98d9907f8e2d26fcabc0bce7b4f5efb9207f1979d2db180f00d2160a84034656952640cde757186e538f7038bb0f626c7b
EBUILD jupyter-core-5.3.0.ebuild 889 BLAKE2B 57882e4d559e174656e6d711f83c8f8ad1b2cf2bd2b883bfbf8554ec03b890b1cc3a36bcd2091d327ef5e12a539c32e2671d753ed68e99311f19f1bfe52d6b09 SHA512 cbee64eda3826a167f0663f122e560dfe465a8a173e8dfa636f6368713b509ae79eda308d889a6db2753d7db0570dc6f083a69c7b2d4bc377da80f6a1324b75d
+EBUILD jupyter-core-5.3.1.ebuild 898 BLAKE2B 132ec168d8acad7332a10d08340a28f0e807675fbeb07c41739fc779c93147800aaa3556a4ddef53e2c7a70b0685bf254a60919863e00469b2f1b83108b742c3 SHA512 1e3fdcbbca1fd3cdf041d034304582a45840bc57339a94e7fdf4d1b6824f47d1b994848ada837baaab02bc103de07e6554552f132011e59094cbe5b11beb06ad
MISC metadata.xml 759 BLAKE2B 4ef6a95640943d1b082bb65ae17515300089c6d78c0aa81410f4c7e57e1447787ad15373f314f8ea5c980459f4e5f74ee54edace2eb9421991e2425793040adc SHA512 d9769460a005d11961ebabc81636065aec545166820e923ab7abd58782e0832592a58611ccb4485164ef7c1c646812e8f608fafb9639525663732dec730542f5
diff --git a/dev-python/jupyter-core/jupyter-core-5.3.1.ebuild b/dev-python/jupyter-core/jupyter-core-5.3.1.ebuild
new file mode 100644
index 000000000000..f2aa50355f98
--- /dev/null
+++ b/dev-python/jupyter-core/jupyter-core-5.3.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Core common functionality of Jupyter projects"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter/jupyter_core/
+ https://pypi.org/project/jupyter-core/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/platformdirs-2.5[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-5.3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/ipython-4.0.1[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs \
+ dev-python/myst-parser \
+ dev-python/sphinx-autodoc-typehints \
+ dev-python/sphinxcontrib-github-alt \
+ dev-python/sphinxcontrib-spelling \
+ dev-python/traitlets
+distutils_enable_tests pytest