summaryrefslogtreecommitdiff
path: root/dev-python/jupyter-console
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-20 10:17:50 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-20 10:17:50 +0100
commit399fa07bfac673a8846466b16c76549e329b55b8 (patch)
tree29af17ef91f1bd986b8e615a96b61db7fad5df14 /dev-python/jupyter-console
parent388a0747e5972613060d5ca13955b5cd7132533d (diff)
gentoo auto-resync : 20:05:2023 - 10:17:50
Diffstat (limited to 'dev-python/jupyter-console')
-rw-r--r--dev-python/jupyter-console/Manifest3
-rw-r--r--dev-python/jupyter-console/jupyter-console-6.6.3.ebuild40
-rw-r--r--dev-python/jupyter-console/metadata.xml21
3 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/jupyter-console/Manifest b/dev-python/jupyter-console/Manifest
new file mode 100644
index 000000000000..7b47e68a3c28
--- /dev/null
+++ b/dev-python/jupyter-console/Manifest
@@ -0,0 +1,3 @@
+DIST jupyter_console-6.6.3.tar.gz 34363 BLAKE2B fd5875f608bec0528f7751b7cb146bff3f5c6caeb531a360eb5dd6164c44b3a4a84d1371756f42c256fbada7572176172894a01bc5b7cca835f12a390815ff5a SHA512 fc896dfc783648127690458712e90eced9578629dd55e3bfc9e15319ffa919c118c78d7872f0274455c3996fa9321bccdfa204b94b45a2de733b7703894c9034
+EBUILD jupyter-console-6.6.3.ebuild 972 BLAKE2B 513d13941d3a6da9f332d6033b43c8dac4d17a99eb05e3b6799b9f9a23497f0ba05263eececc94cd5f350cd6a1fbc734f9443e2aea088d6cddbf6858bdf36401 SHA512 3a31c21cfc68147d30aa7c46c401157afd353b17bbe281e787cae933f773c29b171087ccba2372bde5c82b72f96344c3350c1489c2c3568816027f6607fad751
+MISC metadata.xml 702 BLAKE2B 38bb264e2ab7f1feca67ae6a35d2ee20c04b53188cc7d3a51bd2d1630ba6a9e89ac949013bbd9ac3443331bcf3f115f85537865787daee26949b9773aa9b9197 SHA512 c3f9fb275560a3aef2a5266d2070e3d013f53e2f3f7e1363626b15d290ccd619c65a19d6ee2b849a683a96159c8af29c55c81eff5a333759eae5cd6773736b24
diff --git a/dev-python/jupyter-console/jupyter-console-6.6.3.ebuild b/dev-python/jupyter-console/jupyter-console-6.6.3.ebuild
new file mode 100644
index 000000000000..8709fe346234
--- /dev/null
+++ b/dev-python/jupyter-console/jupyter-console-6.6.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A terminal-based console frontend for Jupyter kernels"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter/jupyter_console/
+ https://pypi.org/project/jupyter-console/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RDEPEND="
+ >=dev-python/ipykernel-6.14[${PYTHON_USEDEP}]
+ dev-python/ipython[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-client-7.0.0[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-core-5.1.0[${PYTHON_USEDEP}]
+ >=dev-python/prompt-toolkit-3.0.30[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-17[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-5.4[${PYTHON_USEDEP}]
+"
+# util-linux provides script(1)
+BDEPEND="
+ test? (
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ sys-apps/util-linux
+ )
+"
+
+distutils_enable_tests pytest
diff --git a/dev-python/jupyter-console/metadata.xml b/dev-python/jupyter-console/metadata.xml
new file mode 100644
index 000000000000..0d62052f276f
--- /dev/null
+++ b/dev-python/jupyter-console/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription>
+ A terminal-based console frontend for Jupyter kernels.
+ This code is based on the single-process IPython terminal.
+ </longdescription>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">jupyter-console</remote-id>
+ <remote-id type="github">jupyter/jupyter_console</remote-id>
+ </upstream>
+</pkgmetadata>