summaryrefslogtreecommitdiff
path: root/dev-python/jupyter-client
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-25 00:07:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-25 00:07:14 +0100
commitf8999218b5a6eafa151e7367030cbfdb69e045ed (patch)
tree0d0e9293bcb75153cd18542369fa789ede9338a0 /dev-python/jupyter-client
parentaa4954f71a3ba2293395a8cce2321a70c39c7554 (diff)
gentoo auto-resync : 25:05:2024 - 00:07:14
Diffstat (limited to 'dev-python/jupyter-client')
-rw-r--r--dev-python/jupyter-client/Manifest2
-rw-r--r--dev-python/jupyter-client/jupyter-client-8.6.2.ebuild56
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/jupyter-client/Manifest b/dev-python/jupyter-client/Manifest
index a856bb3b012e..f24794592931 100644
--- a/dev-python/jupyter-client/Manifest
+++ b/dev-python/jupyter-client/Manifest
@@ -1,3 +1,5 @@
DIST jupyter_client-8.6.1.tar.gz 340957 BLAKE2B a9a7e7818a463927ec11a4adc6758addef38fae45e29be59b388951715898e5bc81e02035c33fa6e4a0208db47a87a2b793258f4a85739925827895ea357b8f8 SHA512 be70d1f250da6698998a5c523d733da386940952487335e615160e04600e00e7ff170cae7f0c03e3a000ecca2bac26855f100c95f2759983c0b50fde10ed8223
+DIST jupyter_client-8.6.2.tar.gz 341102 BLAKE2B d9d04b6b965aa34f6b1dd228d1389a36509415e57cb66b4aede37963b6a48f5133c48e8343bbb54bd775b3faa59db8b248f515caca9dbbe594a9d4ba93a668d7 SHA512 ce0ae60b083ce0a37ddd0249d3caef0581ece61927ae685ee80b55d9431557352f1dce6cf81894d39343087b15cc6ac3449abe88cb4119a0d03824b3642f84ff
EBUILD jupyter-client-8.6.1.ebuild 1561 BLAKE2B 3989da8fa7be0aaa6f313582d2c23aecd337d49d93dc7943aa83d217ca9a9a17a79b08fe416d5b00cd404d275265be047fde60b348545958e97d2b91ca4d78c0 SHA512 adc99b237fe06672d79365e1a1fb89eda2478b5f77b31248ef511a3e8a2042217d5c233fc13e119d1d65860f2f5e6029e99614daf880ae87e83643cea01dc98d
+EBUILD jupyter-client-8.6.2.ebuild 1569 BLAKE2B b21185681d5821a73fcf705327b13da03182ed69f0ac5a891a3a137d84ee7510dcadb0c99266c6c71690c312326a40698209ae9083e41114355195c3a32265a8 SHA512 713ec3d24607c60cddde7148bcce97dab89195fae97055da338a18f9e5385e10eeeefca8175dc11e782903bb8618402a57f9f51569525a2c6edf15a152b50729
MISC metadata.xml 844 BLAKE2B 8beea01f144f8e28b58b1bd4d0d2a32eda4b5e50e479c83ed940cd6894d581aa22418bc2733910465cb6980134c3a29b63a6e31f595d037b9492337285837ac6 SHA512 73f427cc561e728c6f941052a4b6f9c6ec5c9d6ba3bb601bc58313687dfc8d6ed3602e1fb2f7f0ea00aec4360c8c1200334675917d22092ed79585b117865ebd
diff --git a/dev-python/jupyter-client/jupyter-client-8.6.2.ebuild b/dev-python/jupyter-client/jupyter-client-8.6.2.ebuild
new file mode 100644
index 000000000000..2361f98a8227
--- /dev/null
+++ b/dev-python/jupyter-client/jupyter-client-8.6.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Jupyter protocol implementation and client libraries"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter/jupyter_client/
+ https://pypi.org/project/jupyter-client/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos"
+
+RDEPEND="
+ >=dev-python/jupyter-core-5.1[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.8.2[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-23.0[${PYTHON_USEDEP}]
+ >=dev-python/tornado-6.0[${PYTHON_USEDEP}]
+ dev-python/traitlets[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/importlib-metadata-4.8.3[${PYTHON_USEDEP}]
+ ' 3.{8,9})
+"
+BDEPEND="
+ test? (
+ >=dev-python/ipykernel-6.14[${PYTHON_USEDEP}]
+ >=dev-python/pytest-asyncio-0.18[${PYTHON_USEDEP}]
+ >=dev-python/pytest-jupyter-0.4.1[${PYTHON_USEDEP}]
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO: times out
+ tests/test_client.py::TestAsyncKernelClient::test_input_request
+ # TODO
+ tests/test_multikernelmanager.py::TestKernelManager::test_tcp_cinfo
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -o tmp_path_retention_policy=all \
+ -p asyncio -p rerunfailures --reruns=3 -p timeout
+}