summaryrefslogtreecommitdiff
path: root/dev-python/junit-xml/junit-xml-1.9.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /dev-python/junit-xml/junit-xml-1.9.ebuild
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'dev-python/junit-xml/junit-xml-1.9.ebuild')
-rw-r--r--dev-python/junit-xml/junit-xml-1.9.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/junit-xml/junit-xml-1.9.ebuild b/dev-python/junit-xml/junit-xml-1.9.ebuild
new file mode 100644
index 000000000000..b6fa6e5bf110
--- /dev/null
+++ b/dev-python/junit-xml/junit-xml-1.9.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+inherit distutils-r1
+
+DESCRIPTION="Create JUnit XML test result documents"
+HOMEPAGE="
+ https://pypi.org/project/junit-xml/
+ https://github.com/kyrus/python-junit-xml"
+# upstream fails both at uploading to pypi and making tags
+# https://github.com/kyrus/python-junit-xml/issues/69
+# https://github.com/kyrus/python-junit-xml/issues/31
+EGIT_COMMIT="19d3cc333d35dfd2d17d75c506336c15e5c6685a"
+SRC_URI="
+ https://github.com/kyrus/python-junit-xml/archive/${EGIT_COMMIT}.tar.gz
+ -> ${P}.tar.gz"
+S=${WORKDIR}/python-junit-xml-${EGIT_COMMIT}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest