summaryrefslogtreecommitdiff
path: root/dev-python/jsonxs/jsonxs-0.6-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/jsonxs/jsonxs-0.6-r1.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/jsonxs/jsonxs-0.6-r1.ebuild')
-rw-r--r--dev-python/jsonxs/jsonxs-0.6-r1.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/jsonxs/jsonxs-0.6-r1.ebuild b/dev-python/jsonxs/jsonxs-0.6-r1.ebuild
new file mode 100644
index 000000000000..8a367653e9a4
--- /dev/null
+++ b/dev-python/jsonxs/jsonxs-0.6-r1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Get/set values in JSON and Python datastructures"
+HOMEPAGE="https://github.com/fboender/jsonxs"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+python_test() {
+ "${EPYTHON}" jsonxs/jsonxs.py -v || die "Tests failed with ${EPYTHON}"
+}