summaryrefslogtreecommitdiff
path: root/dev-python/jsonschema/jsonschema-3.0.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
commitb7b97785ebbb2f11d24d14dab8b81ed274f4ce6a (patch)
tree9fd110f9fc996e8a4213eeda994a8c112491b86d /dev-python/jsonschema/jsonschema-3.0.1.ebuild
parent066d27181e9a797ad9f8fc43b49fc9a10ff2f707 (diff)
gentoo resync : 19.03.2019
Diffstat (limited to 'dev-python/jsonschema/jsonschema-3.0.1.ebuild')
-rw-r--r--dev-python/jsonschema/jsonschema-3.0.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/jsonschema/jsonschema-3.0.1.ebuild b/dev-python/jsonschema/jsonschema-3.0.1.ebuild
new file mode 100644
index 000000000000..816bd7b644c7
--- /dev/null
+++ b/dev-python/jsonschema/jsonschema-3.0.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="An implementation of JSON-Schema validation for Python"
+HOMEPAGE="https://pypi.org/project/jsonschema/ https://github.com/Julian/jsonschema"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux"
+IUSE="test"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ "
+
+RDEPEND="
+ dev-python/rfc3987[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/strict-rfc3339[${PYTHON_USEDEP}]
+ dev-python/webcolors[${PYTHON_USEDEP}]
+ dev-python/pyrsistent[${PYTHON_USEDEP}]
+ >=dev-python/attrs-17.4.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep \
+ 'dev-python/functools32[${PYTHON_USEDEP}]' 'python2*' pypy)
+ "
+DEPEND="${RDEPEND}
+ >=dev-python/vcversioner-2.16.0.0[${PYTHON_USEDEP}]
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )"
+
+python_test() {
+ "${PYTHON}" -m unittest discover || die "Testing failed with ${EPYTHON}"
+}