summaryrefslogtreecommitdiff
path: root/dev-python/jsonschema/jsonschema-3.0.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-python/jsonschema/jsonschema-3.0.1.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-python/jsonschema/jsonschema-3.0.1.ebuild')
-rw-r--r--dev-python/jsonschema/jsonschema-3.0.1.ebuild43
1 files changed, 0 insertions, 43 deletions
diff --git a/dev-python/jsonschema/jsonschema-3.0.1.ebuild b/dev-python/jsonschema/jsonschema-3.0.1.ebuild
deleted file mode 100644
index f3875be46edf..000000000000
--- a/dev-python/jsonschema/jsonschema-3.0.1.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 python3_{6,7} )
-
-inherit distutils-r1
-
-DESCRIPTION="An implementation of JSON-Schema validation for Python"
-HOMEPAGE="https://pypi.org/project/jsonschema/ https://github.com/Julian/jsonschema"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-BDEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- "
-
-RDEPEND="
- dev-python/rfc3987[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/strict-rfc3339[${PYTHON_USEDEP}]
- dev-python/webcolors[${PYTHON_USEDEP}]
- dev-python/pyrsistent[${PYTHON_USEDEP}]
- >=dev-python/attrs-17.4.0[${PYTHON_USEDEP}]
- $(python_gen_cond_dep \
- 'dev-python/functools32[${PYTHON_USEDEP}]' 'python2*' pypy)
- "
-DEPEND="${RDEPEND}
- >=dev-python/vcversioner-2.16.0.0[${PYTHON_USEDEP}]
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/twisted[${PYTHON_USEDEP}]
- )"
-
-python_test() {
- "${PYTHON}" -m unittest discover || die "Testing failed with ${EPYTHON}"
-}