summaryrefslogtreecommitdiff
path: root/dev-python/jsonschema-spec
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-22 17:28:08 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-22 17:28:08 +0100
commitd79ab35b7ac170babebe8bc151fe5d037c16285c (patch)
treec774a4913f32e952079ae36fc6afd2dad747837f /dev-python/jsonschema-spec
parent992aa50a54a56c9e705ca4e85d809ec8989d74a2 (diff)
gentoo auto-resync : 22:09:2022 - 17:28:08
Diffstat (limited to 'dev-python/jsonschema-spec')
-rw-r--r--dev-python/jsonschema-spec/Manifest2
-rw-r--r--dev-python/jsonschema-spec/jsonschema-spec-0.1.2.ebuild37
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/jsonschema-spec/Manifest b/dev-python/jsonschema-spec/Manifest
index cea66108ffeb..6827bff8437d 100644
--- a/dev-python/jsonschema-spec/Manifest
+++ b/dev-python/jsonschema-spec/Manifest
@@ -1,3 +1,5 @@
DIST jsonschema-spec-0.1.1.gh.tar.gz 21747 BLAKE2B 441f34c62da2d22699379035e20f2ed78a974413ea9c2f80b753cc2b41d978351c69aaa50750139e622d075c4c3979dc43b888bea111a0f4b31fa9d37822a1fa SHA512 b1bdd03c6fc022877d0801d859abe0dd19e066afe2a1eab6c650a8741a50473e74945ddde429508e5dccf379a84b25fbd60c49fdc310aa770bed52b63e60e397
+DIST jsonschema-spec-0.1.2.gh.tar.gz 21782 BLAKE2B 238f035e75ec45edade5fd00269d2fc208a73208d1e07586490728b8c97819d6fddd9b909d2af00e63ebc4c141cb8dbaaf8e3e7ce88c3ff58ada2ba147c1e2c9 SHA512 0cba83a14e88d4fe2fcce9e4d39fa4284f23366a1f8acab16fa4b7b824d0c02bf04429d61c51a39a7a188c4e2b79f4481bba14ca688edee71beb0060e16617e0
EBUILD jsonschema-spec-0.1.1.ebuild 831 BLAKE2B e0c1bbd909288a5d74993a967ce0ea2c139cd66948a7eee73b75f01a52452ef575c026dcda0d719df139b9e9455cb868f7ea27581f55af0e0deeca304b23cb33 SHA512 bb5a3704ca62708f9fb2e71e11634824269b469c0ca85029d0f22ef3c83f44b798f5c2a38b0a6d7d065db31e3dab373d44ca6b8969205079cfc8c9cd56fa7ca2
+EBUILD jsonschema-spec-0.1.2.ebuild 833 BLAKE2B 441675ce28b232a103b4df985e8bf32bde01a6330e03c60a4910ebc5fe579f89f8d609b26ba5a424d3cbe8ad3857318ad6ac5e03086a88d0b4c7faf51a96d872 SHA512 ae23c7466297b8e703507de44773e705e9996f59fcdf18bfc466378cccc920937053cf8b7887e53d2bffd790decad16682638752a0419b33ce0c9f8a846a4a21
MISC metadata.xml 404 BLAKE2B 2e76fe1eb441114cff26e2e60d36d2d38da053ca524a29f568d2b4af325021ab560545da43cdd0d5d3404e73ebcdb9b534da0b7de52c2acee5d3f2ed6511ee4e SHA512 58238e60fc20d210167afe2abcfdbbd826a693b5d587953437294c2c0e1ea9161486e2c583d29a7e2a0c8343e70e7688213ed011eacd155c53e232b336986701
diff --git a/dev-python/jsonschema-spec/jsonschema-spec-0.1.2.ebuild b/dev-python/jsonschema-spec/jsonschema-spec-0.1.2.ebuild
new file mode 100644
index 000000000000..1a6a4f949102
--- /dev/null
+++ b/dev-python/jsonschema-spec/jsonschema-spec-0.1.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="JSONSchema Spec with object-oriented paths"
+HOMEPAGE="
+ https://pypi.org/project/jsonschema-spec/
+ https://github.com/p1c2u/jsonschema-spec/
+"
+SRC_URI="
+ https://github.com/p1c2u/jsonschema-spec/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/jsonschema-4.0.0[${PYTHON_USEDEP}]
+ dev-python/pathable[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
+ dev-python/pathable[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -e '/--cov/d' -i pyproject.toml || die
+ distutils-r1_src_prepare
+}