summaryrefslogtreecommitdiff
path: root/dev-python/jsonschema-path
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-27 07:59:40 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-27 07:59:40 +0100
commitd2ed973482fdd800013658e83a61709b29e0a80f (patch)
tree57ea7666a57b5a05a4c8866e4915e90b4a6e7c94 /dev-python/jsonschema-path
parent9f6a82a85d400d6ae7de04c43cee88dbc6bc4da0 (diff)
gentoo auto-resync : 27:06:2024 - 07:59:39
Diffstat (limited to 'dev-python/jsonschema-path')
-rw-r--r--dev-python/jsonschema-path/Manifest2
-rw-r--r--dev-python/jsonschema-path/jsonschema-path-0.3.3.ebuild47
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/jsonschema-path/Manifest b/dev-python/jsonschema-path/Manifest
index 80f16c92086f..6dc853e8ae4b 100644
--- a/dev-python/jsonschema-path/Manifest
+++ b/dev-python/jsonschema-path/Manifest
@@ -1,3 +1,5 @@
DIST jsonschema-path-0.3.2.gh.tar.gz 39521 BLAKE2B 871bb33c7839a3b9bf66e145c239cd6715cfaa2ae782f28b77de83228136af5259e1757856e47f0ac26f46572911553510a153f4f48e3b1d2a813160eb65c143 SHA512 e49b32c4609238d2808938976bd0022f86837e9d7d296a137d42f8e8c80d20d20fdd23a07b898063536290b36bd72df0abef64b65997a66cb3fb9c403cc275d3
+DIST jsonschema-path-0.3.3.gh.tar.gz 40104 BLAKE2B 00f3551f807a76ca59d7dca55d28dc86f36f94ad03be52376a67f29936a1215e50dc5d4af33aabe29026913737e9f453d466450122411297f714e3557fe06d2e SHA512 846d476285b4c89d0241d18be09eb7c12df855f7b28f0d3ea9942a9d23977f3c051b93a1281f6f5323c2c4bc9c86fe82b5eae1bce647f58d9d2acce65d4f54a8
EBUILD jsonschema-path-0.3.2-r1.ebuild 1125 BLAKE2B 7c002869ed29845946eb3cbfbe18edb24df78c11979219cf5eeb965b1e92f3bb6ddef127d221b61ab1684cf984ec5263fb652cd5bf12e8f3e5a03541c93fcd74 SHA512 660b58dd5dc4c931cd0405bcecd2513abc6e34b679ef6dc1eaa19c839406136c786cbd452651b53a3846c55749204252cfdbb64ed168a6b996ecd226a4b530ce
+EBUILD jsonschema-path-0.3.3.ebuild 1130 BLAKE2B de771b65231b94f4f2d8c4ce3d0d94ac80c4e7c24f22b91b3e903e666871ae94e324b6d94bd83c72b27686e514598fb84378d463136629e8d3b851525bf0f522 SHA512 6bfbf75067d9a155913af58723ff7ecc09895e8bcdd6549d47e1a3adb9846ecd4139c75aa7e247b393ae69ccc063e68812ab8911fce2bec612aac17ec986096e
MISC metadata.xml 404 BLAKE2B 1ca43c4b4650286727d5676f4179f99daa52efeeeded543e3453b91033fb68e6639851b1149a93f28b2fec501acc9623bcb2cd2f58d9df59db505a7ce730807c SHA512 0e041011c6459c256ef992aecea2ac5782d608855da7ddf15340e2a66f89c4542078563dd560a03cc5b13df5c85858c4796d74f39f5a9d257d131f758d5a1bd3
diff --git a/dev-python/jsonschema-path/jsonschema-path-0.3.3.ebuild b/dev-python/jsonschema-path/jsonschema-path-0.3.3.ebuild
new file mode 100644
index 000000000000..ee7d7a29e156
--- /dev/null
+++ b/dev-python/jsonschema-path/jsonschema-path-0.3.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="JSONSchema Spec with object-oriented paths"
+HOMEPAGE="
+ https://pypi.org/project/jsonschema-path/
+ https://github.com/p1c2u/jsonschema-path/
+"
+SRC_URI="
+ https://github.com/p1c2u/jsonschema-path/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+
+# requests seem "optional" but they failed at properly making it
+# optional in poetry, sigh
+RDEPEND="
+ >=dev-python/pathable-0.4.1[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
+ >=dev-python/referencing-0.28.1[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.31.0[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/responses[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e '/--cov/d' pyproject.toml || die
+ # remove random pins due to caret operator
+ sed -i -e 's:\^:>=:' -e 's:,<[0-9.]*::' pyproject.toml || die
+ distutils-r1_src_prepare
+}