summaryrefslogtreecommitdiff
path: root/dev-python/jsonrpclib/jsonrpclib-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-08-02 19:14:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-08-02 19:14:55 +0100
commitb24bd25253fe093f722ab576d29fdc41d04cb1ee (patch)
tree0fcf2afd9f852c4d4c291cf8afaa2c244d598105 /dev-python/jsonrpclib/jsonrpclib-9999.ebuild
parent121ed4eec41fbf03e1998d09eede1bf449da63b9 (diff)
gentoo resync : 02.08.2019
Diffstat (limited to 'dev-python/jsonrpclib/jsonrpclib-9999.ebuild')
-rw-r--r--dev-python/jsonrpclib/jsonrpclib-9999.ebuild15
1 files changed, 8 insertions, 7 deletions
diff --git a/dev-python/jsonrpclib/jsonrpclib-9999.ebuild b/dev-python/jsonrpclib/jsonrpclib-9999.ebuild
index 8744005ec438..c7b359ea5372 100644
--- a/dev-python/jsonrpclib/jsonrpclib-9999.ebuild
+++ b/dev-python/jsonrpclib/jsonrpclib-9999.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
-PYTHON_COMPAT=( python2_7 python3_{5,6} )
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
inherit distutils-r1
@@ -19,12 +19,13 @@ HOMEPAGE="https://github.com/tcalmant/jsonrpclib"
LICENSE="Apache-2.0"
SLOT="0"
-IUSE=""
+IUSE="test"
+RESTRICT="!test? ( test )"
-DEPEND=""
-RDEPEND="${DEPEND}
- dev-python/simplejson"
+RDEPEND="dev-python/simplejson[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND} )"
python_test() {
- esetup.py test || die "tests failed with ${EPYTHON}"
+ esetup.py test
}