summaryrefslogtreecommitdiff
path: root/dev-python/jsonrpclib/jsonrpclib-0.4.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-08-02 19:14:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-08-02 19:14:55 +0100
commitb24bd25253fe093f722ab576d29fdc41d04cb1ee (patch)
tree0fcf2afd9f852c4d4c291cf8afaa2c244d598105 /dev-python/jsonrpclib/jsonrpclib-0.4.0.ebuild
parent121ed4eec41fbf03e1998d09eede1bf449da63b9 (diff)
gentoo resync : 02.08.2019
Diffstat (limited to 'dev-python/jsonrpclib/jsonrpclib-0.4.0.ebuild')
-rw-r--r--dev-python/jsonrpclib/jsonrpclib-0.4.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/jsonrpclib/jsonrpclib-0.4.0.ebuild b/dev-python/jsonrpclib/jsonrpclib-0.4.0.ebuild
new file mode 100644
index 000000000000..c7b359ea5372
--- /dev/null
+++ b/dev-python/jsonrpclib/jsonrpclib-0.4.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/tcalmant/jsonrpclib.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/tcalmant/jsonrpclib/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~mips ~x86"
+fi
+
+DESCRIPTION="python implementation of the JSON-RPC spec (1.0 and 2.0)"
+HOMEPAGE="https://github.com/tcalmant/jsonrpclib"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-python/simplejson[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND} )"
+
+python_test() {
+ esetup.py test
+}